CVE-2005-3973
CVSS4.3
发布时间 :2005-12-03 14:03:00
修订时间 :2011-03-07 21:27:27
NMCOPS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Drupal 4.5.0 through 4.5.5 and 4.6.0 through 4.6.3 allow remote attackers to inject arbitrary web script or HTML via various HTML tags and values, such as the (1) legend tag and the value parameter used in (2) label and (3) input tags, possibly due to an incomplete blacklist.


[CNNVD]Drupal Submitted Content 多个跨站脚本攻击漏洞(CNNVD-200512-048)

        Multiple cross-site scripting (XSS) vulnerabilities in Drupal 4.5.0到4.5.5和4.6.0到4.6.3版本存在多个跨站脚本攻击漏洞。 远程攻击者可以借助各种HTML标号和值,例如 (1)legend标号和(2)label 和 (3)input标号中的value参数,注入任意的 web 脚本或 HTML,可能由黑名单不完整所致。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:drupal:drupal:4.5.5
cpe:/a:drupal:drupal:4.6.0
cpe:/a:drupal:drupal:4.5.2
cpe:/a:drupal:drupal:4.6.1
cpe:/a:drupal:drupal:4.6.3
cpe:/a:drupal:drupal:4.5.4
cpe:/a:drupal:drupal:4.5.0
cpe:/a:drupal:drupal:4.5.3
cpe:/a:drupal:drupal:4.5.1
cpe:/a:drupal:drupal:4.6.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3973
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3973
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-048
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15677
(PATCH)  BID  15677
http://www.securityfocus.com/archive/1/archive/1/418292/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051201 [DRUPAL-SA-2005-007] Drupal 4.6.4 / 4.5.6 fixes XSS issue
http://secunia.com/advisories/17824
(VENDOR_ADVISORY)  SECUNIA  17824
http://drupal.org/files/sa-2005-007/advisory.txt
(VENDOR_ADVISORY)  CONFIRM  http://drupal.org/files/sa-2005-007/advisory.txt
http://www.vupen.com/english/advisories/2005/2684
(UNKNOWN)  VUPEN  ADV-2005-2684
http://drupal.org/files/sa-2005-007/4.6.3.patch
(UNKNOWN)  MISC  http://drupal.org/files/sa-2005-007/4.6.3.patch
http://www.debian.org/security/2006/dsa-958
(UNKNOWN)  DEBIAN  DSA-958
http://secunia.com/advisories/18630
(UNKNOWN)  SECUNIA  18630

- 漏洞信息

Drupal Submitted Content 多个跨站脚本攻击漏洞
中危 跨站脚本
2005-12-03 00:00:00 2005-12-06 00:00:00
远程  
        Multiple cross-site scripting (XSS) vulnerabilities in Drupal 4.5.0到4.5.5和4.6.0到4.6.3版本存在多个跨站脚本攻击漏洞。 远程攻击者可以借助各种HTML标号和值,例如 (1)legend标号和(2)label 和 (3)input标号中的value参数,注入任意的 web 脚本或 HTML,可能由黑名单不完整所致。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://drupal.org/files/projects/drupal-4.5.6.tar.gz
        http://drupal.org/files/projects/drupal-4.6.4.tar.gz
        

- 漏洞信息 (F43469)

Debian Linux Security Advisory 958-1 (PacketStormID:F43469)
2006-01-29 00:00:00
Debian  debian.org
advisory,remote,web,arbitrary,vulnerability,xss
linux,debian
CVE-2005-3973,CVE-2005-3974,CVE-2005-3975
[点击下载]

Debian Security Advisory DSA 958-1 - Several security related problems have been discovered in Drupal. Several cross-site scripting vulnerabilities allow remote attackers to inject arbitrary web script or HTML. When running on PHP5, Drupal does not correctly enforce user privileges, which allows remote attackers to bypass the 'access user profiles' permission. An interpretation conflict allows remote authenticated users to inject arbitrary web script or HTML via HTML in a file with a GIF or JPEG file extension.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 958-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 27th, 2006                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : drupal
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE IDs        : CVE-2005-3973 CVE-2005-3974CVE-2005-3975
BugTraq IDs    : 15674 15677 15663

Several security related problems have been discovered in drupal, a
fully-featured content management/discussion engine.  The Common
Vulnerabilities and Exposures project identifies the following
vulnerabilities:

CVE-2005-3973

    Several cross-site scripting vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML.

CVE-2005-3974

    When running on PHP5, Drupal does not correctly enforce user
    privileges, which allows remote attackers to bypass the "access
    user profiles" permission.

CVE-2005-3975

    An interpretation conflict allows remote authenticated users to
    inject arbitrary web script or HTML via HTML in a file with a GIF
    or JPEG file extension.

The old stable distribution (woody) does not contain drupal packages.

For the stable distribution (sarge) these problems have been fixed in
version 4.5.3-5.

For the unstable distribution (sid) these problems have been fixed in
version 4.5.6-1.

We recommend that you upgrade your drupal package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-5.dsc
      Size/MD5 checksum:      609 55d91c43600aa680ba52b17c717ea8e3
    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-5.diff.gz
      Size/MD5 checksum:    80360 5349b33da1964a91340d7e98db1fc924
    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3.orig.tar.gz
      Size/MD5 checksum:   471540 bf093c4c8aca7bba62833ea1df35702f

  Architecture independent components:

    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-5_all.deb
      Size/MD5 checksum:   501814 925cd8f84b2ec34f98663d849816066b


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFD2e+SW5ql+IAeqTIRAp1tAJ43GHPxpzbWi1oXhuCbBhWJCtmJhwCfXa9S
/T2Dx5Xl5SrmnoKDDmLD6wI=
=UvXv
-----END PGP SIGNATURE-----

    

- 漏洞信息

21351
Drupal Multiple HTML/SGML Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

Drupal contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the HTML/SGML input such as the 'legend' tag and the 'value' parameter used in 'input' and 'label tags. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-11-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.5.6 if using 4.5x or 4.6.4 if using 4.6.x, or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Drupal Submitted Content HTML Injection Vulnerability
Input Validation Error 15677
Yes No
2005-12-01 12:00:00 2006-02-07 08:54:00
Ahmed Saad is credited with the discovery of this vulnerability.

- 受影响的程序版本

Drupal Drupal 4.6.3
Drupal Drupal 4.6.2
Drupal Drupal 4.6.1
Drupal Drupal 4.6
Drupal Drupal 4.5.5
Drupal Drupal 4.5.4
Drupal Drupal 4.5.3
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.1
Drupal Drupal 4.5.2
Drupal Drupal 4.5.2
Drupal Drupal 4.5.1
Drupal Drupal 4.5
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Drupal Drupal 4.6.4
Drupal Drupal 4.5.6

- 不受影响的程序版本

Drupal Drupal 4.6.4
Drupal Drupal 4.5.6

- 漏洞讨论

Drupal is prone to an HTML-injection vulnerability. This issue is due to the application's failure to properly sanitize user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing for theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

- 漏洞利用

No exploit is required.

- 解决方案


Debian Linux has released security advisory DSA 958-1 addressing this and other issues. Please see the referenced advisory for further information.

The vendor has released updates addressing this issue:


Drupal Drupal 4.5

Drupal Drupal 4.5.1

Drupal Drupal 4.5.2

Drupal Drupal 4.5.2

Drupal Drupal 4.5.3

Drupal Drupal 4.5.4

Drupal Drupal 4.5.5

Drupal Drupal 4.6

Drupal Drupal 4.6.1

Drupal Drupal 4.6.2

Drupal Drupal 4.6.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站