CVE-2005-3967
CVSS4.3
发布时间 :2005-12-03 14:03:00
修订时间 :2011-03-07 21:27:27
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the dosearchsite.action module in Atlassian Confluence 2.0.1 Build 321 allows remote attackers to inject arbitrary web script or HTML via the searchQuery.queryString search module parameter.


[CNNVD]Atlassian Confluence Search 跨站脚本攻击漏洞(CNNVD-200512-047)

        Atlassian Confluence 2.0.1 Build 321的 dosearchsite.action 模块存在跨站脚本攻击漏洞。远程攻击者可以通过searchQuery.queryString search module参数,注入任意Web脚本或HTML 。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3967
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3967
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-047
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/17833
(VENDOR_ADVISORY)  SECUNIA  17833
http://www.vupen.com/english/advisories/2005/2691
(UNKNOWN)  VUPEN  ADV-2005-2691
http://www.securityfocus.com/bid/15688
(UNKNOWN)  BID  15688
http://www.osvdb.org/21377
(UNKNOWN)  OSVDB  21377
http://pridels0.blogspot.com/2005/12/confluence-enterprise-wiki-xss-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/confluence-enterprise-wiki-xss-vuln.html

- 漏洞信息

Atlassian Confluence Search 跨站脚本攻击漏洞
中危 跨站脚本
2005-12-03 00:00:00 2006-06-09 00:00:00
远程  
        Atlassian Confluence 2.0.1 Build 321的 dosearchsite.action 模块存在跨站脚本攻击漏洞。远程攻击者可以通过searchQuery.queryString search module参数,注入任意Web脚本或HTML 。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://jira.atlassian.com/browse/CONF-4825

- 漏洞信息

21377
Atlassian Confluence Search Module searchQuery Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Workaround, Patch / RCS, Upgrade
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

Atlassian Confluence contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the variable "searchQuery" in the "dosearchsite.action" module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-02 Unknow
Unknow 2005-12-05

- 解决方案

Upgrade to version 2.0.2 or higher, as it has been reported to fix this vulnerability. Additionally, the vendor has released a patch to address this issue, or users may opt to apply the temporary workaround described in the vendor advisory.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站