发布时间 :2005-12-01 01:03:00
修订时间 :2009-10-09 00:33:16

[原文]PHP file include vulnerability in SocketKB 1.1.0 and earlier allows remote attackers to include arbitrary local files via the __f parameter.

[CNNVD]SocketKB Index.PHP SQL注入漏洞(CNNVD-200512-006)

        SocketKB 1.1.0及之前版本存在PHP文件包含漏洞。 远程攻击者可以通过__f 参数放入任意的本地文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

SocketKB Index.PHP SQL注入漏洞
高危 输入验证
2005-12-01 00:00:00 2005-12-01 00:00:00
        SocketKB 1.1.0及之前版本存在PHP文件包含漏洞。 远程攻击者可以通过__f 参数放入任意的本地文件。

- 公告与补丁


- 漏洞信息

SocketKB index.php __f Parameter Local File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

SocketKB contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to index.php not properly sanitizing user input supplied to the '__f' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-11-29 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

SocketKB Index.PHP SQL Injection Vulnerability
Input Validation Error 15650
Yes No
2005-11-30 12:00:00 2005-11-30 12:00:00
r0t is credited with the discovery of this vulnerability.

- 受影响的程序版本

SocketKB SocketKB 1.1 .0

- 漏洞讨论

SocketKB is prone to an SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

No exploit is required.

Example URI have been provided:[SQL][SQL]

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考