CVE-2005-3908
CVSS4.3
发布时间 :2005-11-30 06:03:00
修订时间 :2011-03-07 21:27:21
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in search.php in GhostScripter Amazon Shop 5.0.0, and other versions before 5.0.2, allows remote attackers to inject web script or HTML via the query parameter.


[CNNVD]GhostScripter Amazon Shop search.php 跨站脚本漏洞(CNNVD-200511-492)

        GhostScripter Amazon Shop是一款网络购物程序。
        GhostScripter Amazon Shop 5.0.0以及5.0.2之前其他版本的search.php存在跨站脚本漏洞,可让远程攻击者通过query参数注入Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:amazon_shop:amazon_shop:5.0.1
cpe:/a:amazon_shop:amazon_shop:5.0.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3908
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3908
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-492
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2630
(UNKNOWN)  VUPEN  ADV-2005-2630
http://www.securityfocus.com/bid/15634
(UNKNOWN)  BID  15634
http://www.osvdb.org/21371
(UNKNOWN)  OSVDB  21371
http://www.attrition.org/pipermail/vim/2007-May/001603.html
(UNKNOWN)  VIM  20070509 21371: GhostScripter Amazon Shop search.php query Variable XSS (fwd)
http://secunia.com/advisories/17750
(VENDOR_ADVISORY)  SECUNIA  17750
http://pridels0.blogspot.com/2005/11/amazon-shop-500-xss-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/11/amazon-shop-500-xss-vuln.html

- 漏洞信息

GhostScripter Amazon Shop search.php 跨站脚本漏洞
中危 跨站脚本
2005-11-30 00:00:00 2007-05-15 00:00:00
远程  
        GhostScripter Amazon Shop是一款网络购物程序。
        GhostScripter Amazon Shop 5.0.0以及5.0.2之前其他版本的search.php存在跨站脚本漏洞,可让远程攻击者通过query参数注入Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

21371
GhostScripter Amazon Shop search.php query Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

GhostScripter Amazon Shop contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "query" variable upon submission to the search.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-26 Unknow
2005-11-26 Unknow

- 解决方案

Upgrade to version 5.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站