CVE-2005-3903
CVSS4.6
发布时间 :2005-12-14 06:03:00
修订时间 :2008-09-05 16:55:36
NMCOPS    

[原文]Buffer overflow in uidadmin in SCO Unixware 7.1.3 and 7.1.4 allows local users to execute arbitrary code via a -S (scheme) argument that specifies a large file, a different vulnerability than CVE-2001-1063.


[CNNVD]SCO UnixWare UIDAdmin本地溢出漏洞(CNNVD-200512-285)

        UnixWare是由SCO公司开发和维护的商业性质Unix操作系统。
        Unixware捆绑的uidadmin二进制程序中存在本地溢出漏洞,本地攻击者可能利用此漏洞提升自己的权限。如果攻击者能够创建大于1600字节的文件并使用uidadmin的"-S"选项提供该文件路径的话,就会导致栈溢出,允许以root用户权限执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sco:unixware:7.1.4
cpe:/o:sco:unixware:7.1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3903
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3903
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-285
(官方数据源) CNNVD

- 其它链接及资源

http://www.idefense.com/application/poi/display?id=350&type=vulnerabilities&flashstatus=true
(VENDOR_ADVISORY)  IDEFENSE  20051212 SCO Unixware Setuid 'uidadmin' Scheme Buffer Overflow Vulnerability
http://securitytracker.com/id?1015342
(VENDOR_ADVISORY)  SECTRACK  1015342
http://secunia.com/advisories/17986
(VENDOR_ADVISORY)  SECUNIA  17986
http://www.securityfocus.com/bid/15811
(UNKNOWN)  BID  15811
ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.54
(UNKNOWN)  SCO  SCOSA-2005.54
http://xforce.iss.net/xforce/xfdb/23550
(UNKNOWN)  XF  unixware-uidadmin-bo(23550)
http://support.avaya.com/elmodocs2/security/ASA-2006-034.htm
(UNKNOWN)  CONFIRM  http://support.avaya.com/elmodocs2/security/ASA-2006-034.htm
http://securityreason.com/securityalert/251
(UNKNOWN)  SREASON  251
http://secunia.com/advisories/18660
(UNKNOWN)  SECUNIA  18660

- 漏洞信息

SCO UnixWare UIDAdmin本地溢出漏洞
中危 缓冲区溢出
2005-12-14 00:00:00 2005-12-14 00:00:00
本地  
        UnixWare是由SCO公司开发和维护的商业性质Unix操作系统。
        Unixware捆绑的uidadmin二进制程序中存在本地溢出漏洞,本地攻击者可能利用此漏洞提升自己的权限。如果攻击者能够创建大于1600字节的文件并使用uidadmin的"-S"选项提供该文件路径的话,就会导致栈溢出,允许以root用户权限执行任意代码。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.54

- 漏洞信息 (F42279)

iDEFENSE Security Advisory 2005-12-12.t (PacketStormID:F42279)
2005-12-14 00:00:00
iDefense Labs  idefense.com
advisory,overflow,local,root
unixware
CVE-2005-3903
[点击下载]

iDEFENSE Security Advisory 12.12.05 - Local exploitation of a buffer overflow vulnerability in the uidadmin binary included in multiple versions of The SCO Group Inc.'s Unixware allows attackers to gain root privileges. iDefense has confirmed the existence of this vulnerability in SCO Unixware versions 7.1.3 and 7.1.4. All previous versions of SCO Unixware are suspected to be vulnerable.

SCO Unixware Setuid 'uidadmin' Scheme Buffer Overflow Vulnerability

iDefense Security Advisory 12.12.05

www.iDefense.com/application/poi/display?id=350&type=vulnerabilities
December 12, 2005

I. BACKGROUND

SCO Unixware is a Unix operating system that runs on many OEM platforms.

II. DESCRIPTION

Local exploitation of a buffer overflow vulnerability in the uidadmin
binary included in multiple versions of The SCO Group Inc.'s Unixware
allows attackers to gain root privileges.

The vulnerability specifically exists because of a failure to check the
length of user specified file input. If the user prepares a file longer
than 1,600 bytes and supplies the path to that file using the "-S"
option of uidadmin, a stack based buffer overflow occurs. This leads to
the execution of arbitrary code with root privileges, as uidadmin is
setuid root by default.

III. ANALYSIS

Successful exploitation of this vulnerability requires that a user have
local access to the system. This would allow the user to gain super user
privileges.

IV. DETECTION

iDefense has confirmed the existence of this vulnerability in SCO
Unixware versions 7.1.3 and 7.1.4. All previous versions of SCO Unixware
are  suspected to be vulnerable.

V. WORKAROUND

Remove the setuid bit from the ppp binary:

  chmod u-s /unixware/usr/bin/uidadmin

VI. VENDOR RESPONSE

The vendor has released the following update to address this
vulnerability:

  ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.54

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CVE-2005-3903 to this issue. This is a candidate for inclusion in
the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

VIII. DISCLOSURE TIMELINE

10/12/2005  Initial vendor notification
10/13/2005  Initial vendor response
12/12/2005  Coordinated public disclosure

IX. CREDIT

iDefense Labs is credited with the discovery of this vulnerability.

Get paid for vulnerability research
http://www.iDefense.com/poi/teams/vcp.jsp

Free tools, research and upcoming events
http://labs.iDefense.com

X. LEGAL NOTICES

Copyright     

- 漏洞信息

21644
SCO UnixWare uidadmin -S Parameter Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-12-12 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SCO UnixWare UIDAdmin Local Buffer Overflow Vulnerability
Boundary Condition Error 15811
No Yes
2005-12-12 12:00:00 2006-02-07 08:55:00
Discovery is credited to iDEFENSE Labs.

- 受影响的程序版本

SCO Unixware 7.1.4
SCO Unixware 7.1.3
Avaya Intuity Audix R5 0

- 漏洞讨论

SCO UnixWare is prone to a local buffer-overflow vulnerability.

The vulnerability presents itself when the application processes excessive data supplied to the 'uidadmin' utility.

UnixWare 7.1.3 and UnixWare 7.1.4 are affected by this issue. Previous versions may also be affected.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案


Please see the referenced advisories for further information:

- SCO has released advisory SCOSA-2005.54 to address this issue.
- Avaya has released advisory ASA-2006-034 detailing affected Avaya products.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站