CVE-2005-3902
CVSS4.3
发布时间 :2005-11-29 18:03:00
修订时间 :2016-10-17 23:37:58
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in gui/errordocs/index.php in Virtual Hosting Control System (VHCS) 2.2.0 through 2.4.6.2 allows remote attackers to inject arbitrary web script or HTML via query strings that are included in an error message, as demonstrated using a parameter containing script.


[CNNVD]Virtual Hosting Control System (VHCS) 错误消息跨站脚本漏洞(CNNVD-200511-451)

        Virtual Hosting Control System是一款虚拟主机管理系统软件。
        Virtual Hosting Control System (VHCS) 2.2.0至2.4.6.2的gui/errordocs/index.php存在跨站脚本漏洞,可让远程攻击者通过包含在错误消息中的查询字符串注入任意Web脚本或HTML,如使用包含脚本的参数所示。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:virtual_hosting_control_system:virtual_hosting_control_system:2.4
cpe:/a:virtual_hosting_control_system:virtual_hosting_control_system:2.2
cpe:/a:virtual_hosting_control_system:virtual_hosting_control_system:2.4.6
cpe:/a:virtual_hosting_control_system:virtual_hosting_control_system:2.4.6.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3902
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3902
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-451
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2005-November/039000.html
(VENDOR_ADVISORY)  FULLDISC  20051122 VHCS 2.x HTTP Error Cross Site Scripting
http://marc.info/?l=bugtraq&m=113269811630139&w=2
(UNKNOWN)  BUGTRAQ  20051122 VHCS 2.x HTTP Error Cross Site Scripting
http://moritz-naumann.com/adv/0006/vhcsxss/0006.txt
(VENDOR_ADVISORY)  MISC  http://moritz-naumann.com/adv/0006/vhcsxss/0006.txt
http://securityreason.com/securityalert/202
(UNKNOWN)  SREASON  202
http://www.securityfocus.com/bid/15538
(UNKNOWN)  BID  15538
http://xforce.iss.net/xforce/xfdb/23209
(UNKNOWN)  XF  vhcs-http-error-xss(23209)

- 漏洞信息

Virtual Hosting Control System (VHCS) 错误消息跨站脚本漏洞
中危 跨站脚本
2005-11-29 00:00:00 2005-11-29 00:00:00
远程  
        Virtual Hosting Control System是一款虚拟主机管理系统软件。
        Virtual Hosting Control System (VHCS) 2.2.0至2.4.6.2的gui/errordocs/index.php存在跨站脚本漏洞,可让远程攻击者通过包含在错误消息中的查询字符串注入任意Web脚本或HTML,如使用包含脚本的参数所示。

- 公告与补丁

        暂无数据

- 漏洞信息

21060
VHCS Error Page (vhcs/gui/errordocs/index.php) XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

VHCS contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user input when returning with an error page (vhcs/gui/errordocs/index.php). This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.4.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站