发布时间 :2005-11-29 16:03:00
修订时间 :2016-10-17 23:37:51

[原文]Multiple cross-site scripting (XSS) vulnerabilities in in Open Ticket Request System (OTRS) 1.0.0 through 1.3.2 and 2.0.0 through 2.0.3 allow remote authenticated users to inject arbitrary web script or HTML via (1) hex-encoded values in the QueueID parameter and (2) Action parameters.

[CNNVD]Open Ticket Request System (OTRS) 多个跨站脚本漏洞(CNNVD-200511-474)

        Open Ticket Request System (OTRS) 1.0.0至1.3.2以及2.0.0至2.0.3的index.pl存在多个跨站脚本漏洞,可让远程认证的用户通过(1)QueueID参数中十六进制编码的值以及(2)"操作"参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:otrs:otrs:1.3.2Open Ticket Request System (OTRS) 1.3.2
cpe:/a:otrs:otrs:1.0.0Open Ticket Request System (OTRS) 1.0.0
cpe:/a:otrs:otrs:2.0.2Open Ticket Request System (OTRS) 2.0.2
cpe:/a:otrs:otrs:2.0.3Open Ticket Request System (OTRS) 2.0.3
cpe:/a:otrs:otrs:2.0.0Open Ticket Request System (OTRS) 2.0.0
cpe:/a:otrs:otrs:2.0.1Open Ticket Request System (OTRS) 2.0.1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  FULLDISC  20051122 OTRS 1.x/2.x Multiple Security Issues
(UNKNOWN)  BUGTRAQ  20051122 OTRS 1.x/2.x Multiple Security Issues
(PATCH)  BID  15537
(UNKNOWN)  VUPEN  ADV-2005-2535
(UNKNOWN)  XF  otrs-queue-selection-xss(23356)
(UNKNOWN)  XF  otrs-index-xss(23359)

- 漏洞信息

Open Ticket Request System (OTRS) 多个跨站脚本漏洞
中危 跨站脚本
2005-11-29 00:00:00 2005-11-30 00:00:00
        Open Ticket Request System (OTRS) 1.0.0至1.3.2以及2.0.0至2.0.3的index.pl存在多个跨站脚本漏洞,可让远程认证的用户通过(1)QueueID参数中十六进制编码的值以及(2)"操作"参数注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

OTRS (Open Ticket Request System) Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

OTRS contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "QueueID" or "Action" variables upon submission to the script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-22 2005-10-17
Unknow Unknow

- 解决方案

Upgrade to version 2.0.4 or higher or 1.3.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者