CVE-2005-3885
CVSS2.1
发布时间 :2005-11-29 14:03:00
修订时间 :2008-09-05 16:55:33
NMCOPS    

[原文]The ps2epsi extension shell script (ps2epsi.sh) in Inkscape before 0.41 allows local users to overwrite arbitrary files via a symlink attack on the tmpepsifile.epsi temporary file.


[CNNVD]Inkscape不安全的临时文件创建漏洞(CNNVD-200511-438)

        inkscape是一个开放原始码的向量绘图软件,而且功能也十分强大,除了基本的点、线、面、圆形、矩形、曲线之外,也可以做到三维颜色等等高级功能。
        Inkscape 0.41之前版本中的ps2epsi扩展shell脚本(ps2epsi.sh),可让本地用户通过对tmpepsifile.epsi临时文件的符号链接攻击覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3885
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3885
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-438
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14522
(PATCH)  BID  14522
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=321501
(UNKNOWN)  CONFIRM  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=321501
http://www.ubuntulinux.org/support/documentation/usn/usn-223-1
(UNKNOWN)  UBUNTU  USN-223-1
http://www.debian.org/security/2005/dsa-916
(UNKNOWN)  DEBIAN  DSA-916
http://secunia.com/advisories/17886
(UNKNOWN)  SECUNIA  17886
http://secunia.com/advisories/17882
(UNKNOWN)  SECUNIA  17882
http://secunia.com/advisories/16343
(UNKNOWN)  SECUNIA  16343

- 漏洞信息

Inkscape不安全的临时文件创建漏洞
低危 设计错误
2005-11-29 00:00:00 2005-11-29 00:00:00
本地  
        inkscape是一个开放原始码的向量绘图软件,而且功能也十分强大,除了基本的点、线、面、圆形、矩形、曲线之外,也可以做到三维颜色等等高级功能。
        Inkscape 0.41之前版本中的ps2epsi扩展shell脚本(ps2epsi.sh),可让本地用户通过对tmpepsifile.epsi临时文件的符号链接攻击覆盖任意文件。

- 公告与补丁

        暂无数据

- 漏洞信息 (F42230)

Debian Linux Security Advisory 916-1 (PacketStormID:F42230)
2005-12-14 00:00:00
Debian  security.debian.org
advisory,overflow,arbitrary,shell,vulnerability
linux,debian
CVE-2005-3737,CVE-2005-3885
[点击下载]

Debian Security Advisory DSA 916-1 - Several vulnerabilities have been discovered in Inkscape, a vector-based drawing program. Joxean Koret discovered a buffer overflow in the SVG parsing routines that can lead to the execution of arbitrary code. Javier Fernandez-Sanguino Pena noticed that the ps2epsi extension shell script uses a hardcoded temporary file making it vulnerable to symlink attacks.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 916-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
December 7th, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : inkscape
Vulnerability  : buffer overflow
Problem type   : local (remote)
Debian-specific: no
CVE ID         : CVE-2005-3737 CVE-2005-3885
BugTraq ID     : 14522
Debian Bug     : 321501 330894

Several vulnerabilities have been discovered in Inkscape, a
vector-based drawing program.  The Common Vulnerabilities and
Exposures project identifies the following problems:

CVE-2005-3737

    Joxean Koret discovered a buffer overflow in the SVG parsing
    routines that can lead to the execution of arbitrary code.

CVE-2005-3885

    Javier Fern    

- 漏洞信息

18636
Inkscape ps2epsi.sh Symlink Arbitrary File Overwrite
Local Access Required Race Condition

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-08-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.42 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Inkscape Insecure Temporary File Creation Vulnerability
Design Error 14522
No Yes
2005-08-09 12:00:00 2006-04-17 05:11:00
Javier Fernandez-Sanguino Pena is credited with the discovery of this vulnerability.

- 受影响的程序版本

Inkscape Inkscape 0.41
Inkscape Inkscape 0.40
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Inkscape Inkscape 0.42
+ Gentoo Linux

- 不受影响的程序版本

Inkscape Inkscape 0.42
+ Gentoo Linux

- 漏洞讨论

Inkscape creates temporary files in the '/tmp' directory in an insecure manner. An attacker with local access may overwrite or create files using symbolic-link attacks.

This type of attack can result in a denial of service or loss of data within the context of the affected application. Other attacks may be possible.

- 漏洞利用

An exploit is not required.

- 解决方案


The vendor has released version 0.42.

Please see the referenced advisories for more information.


Inkscape Inkscape 0.40

Inkscape Inkscape 0.41

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站