CVE-2005-3862
CVSS7.5
发布时间 :2005-11-29 06:03:00
修订时间 :2011-03-07 21:27:17
NMCOP    

[原文]Buffer overflow in unalz before 0.53 allows remote attackers to execute arbitrary code via long file names in ALZ archives.


[CNNVD]unalz ALZ长文件名缓冲区溢出漏洞(CNNVD-200511-446)

        unalz是ALZ文档的解压程序。
        unalz 0.53之前版本存在缓冲区溢出,可让溢出攻击者通过ALZ归档文件中的长文件名执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:unalz:unalz:0.3
cpe:/a:unalz:unalz:0.31
cpe:/a:unalz:unalz:0.23
cpe:/a:unalz:unalz:0.22
cpe:/a:unalz:unalz:0.51
cpe:/a:unalz:unalz:0.4
cpe:/a:unalz:unalz:0.5
cpe:/a:unalz:unalz:0.52
cpe:/a:unalz:unalz:0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3862
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3862
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-446
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15577
(PATCH)  BID  15577
http://secunia.com/advisories/17774
(VENDOR_ADVISORY)  SECUNIA  17774
http://www.vupen.com/english/advisories/2005/2604
(UNKNOWN)  VUPEN  ADV-2005-2604
http://www.kipple.pe.kr/win/unalz/
(UNKNOWN)  CONFIRM  http://www.kipple.pe.kr/win/unalz/
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=340842
(VENDOR_ADVISORY)  MISC  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=340842
http://xforce.iss.net/xforce/xfdb/23267
(UNKNOWN)  XF  unalz-alz-archive-bo(23267)
http://www.osvdb.org/21160
(UNKNOWN)  OSVDB  21160
http://www.debian.org/security/2006/dsa-959
(UNKNOWN)  DEBIAN  DSA-959
http://secunia.com/advisories/18665
(UNKNOWN)  SECUNIA  18665

- 漏洞信息

unalz ALZ长文件名缓冲区溢出漏洞
高危 缓冲区溢出
2005-11-29 00:00:00 2005-11-29 00:00:00
远程  
        unalz是ALZ文档的解压程序。
        unalz 0.53之前版本存在缓冲区溢出,可让溢出攻击者通过ALZ归档文件中的长文件名执行任意代码。

- 公告与补丁

        暂无数据

- 漏洞信息 (F43507)

Debian Linux Security Advisory 959-1 (PacketStormID:F43507)
2006-02-02 00:00:00
Debian  debian.org
advisory,arbitrary,code execution
linux,debian
CVE-2005-3862
[点击下载]

Debian Security Advisory DSA 959-1 - The Debian Audit Project discovered that unalz, a decompressor for ALZ archives, performs insufficient bounds checking when parsing file names. This can lead to arbitrary code execution if an attacker provides a crafted ALZ archive.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 959-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 30th, 2006                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : unalz
Vulnerability  : buffer overflow
Problem-Type   : local (remote)
Debian-specific: no
CVE ID         : CVE-2005-3862
Debian Bug     : 340842

Ulf H    

- 漏洞信息

21160
unalz Archive Extraction Filename Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

A remote overflow exists in unalz. The application fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted 'ALZ' archive containing a file with an overly long filename, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-11-26 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.53 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站