CVE-2005-3849
CVSS4.3
发布时间 :2005-11-26 19:03:00
修订时间 :2011-03-07 21:27:15
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the Search module in PmWiki up to 2.0.12 allows remote attackers to inject arbitrary web script or HTML via the q parameter.


[CNNVD]PmWiki search模块跨站脚本漏洞(CNNVD-200511-419)

        PmWiki是一个基于PHP的wiki引擎,其主要特点是小巧易用,各项wiki比较完善。
        PmWiki直到2.0.12版本的search模块存在跨站脚本(XSS)漏洞,可让远程攻击者通过q参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pmwiki:pmwiki:2.0.1PmWiki 2.0.1
cpe:/a:pmwiki:pmwiki:2.0.5PmWiki 2.0.5
cpe:/a:pmwiki:pmwiki:2.0.8PmWiki 2.0.8
cpe:/a:pmwiki:pmwiki:2.0.12PmWiki 2.0.12
cpe:/a:pmwiki:pmwiki:2.0.0PmWiki 2.0.0
cpe:/a:pmwiki:pmwiki:2.0.6PmWiki 2.0.6
cpe:/a:pmwiki:pmwiki:2.0.4PmWiki 2.0.4
cpe:/a:pmwiki:pmwiki:2.0.7PmWiki 2.0.7
cpe:/a:pmwiki:pmwiki:2.0.2PmWiki 2.0.2
cpe:/a:pmwiki:pmwiki:2.0.9PmWiki 2.0.9
cpe:/a:pmwiki:pmwiki:2.0.10PmWiki 2.0.10
cpe:/a:pmwiki:pmwiki:2.0.11PmWiki 2.0.11
cpe:/a:pmwiki:pmwiki:2.0.3PmWiki 2.0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3849
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3849
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-419
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15539
(PATCH)  BID  15539
http://www.securityfocus.com/archive/1/archive/1/417432/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051122 PmWiki 2.0.12 Cross Site Scripting
http://secunia.com/advisories/17707
(VENDOR_ADVISORY)  SECUNIA  17707
http://moritz-naumann.com/adv/0005/pmwiki/0005.txt
(VENDOR_ADVISORY)  MISC  http://moritz-naumann.com/adv/0005/pmwiki/0005.txt
http://www.vupen.com/english/advisories/2005/2532
(UNKNOWN)  VUPEN  ADV-2005-2532
http://www.osvdb.org/21056
(UNKNOWN)  OSVDB  21056
http://securityreason.com/securityalert/201
(UNKNOWN)  SREASON  201

- 漏洞信息

PmWiki search模块跨站脚本漏洞
中危 跨站脚本
2005-11-26 00:00:00 2005-11-28 00:00:00
远程  
        PmWiki是一个基于PHP的wiki引擎,其主要特点是小巧易用,各项wiki比较完善。
        PmWiki直到2.0.12版本的search模块存在跨站脚本(XSS)漏洞,可让远程攻击者通过q参数注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

21056
PmWiki Search q Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

PmWiki contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "q" variable upon submission to the search module (pagelist.php). This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-22 Unknow
2005-11-22 Unknow

- 解决方案

Upgrade to version 2.0.13 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站