CVE-2005-3841
CVSS4.3
发布时间 :2005-11-26 17:03:00
修订时间 :2011-03-07 21:27:15
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in kPlaylist 1.6 (build 400), and possibly other versions, allows remote attackers to inject arbitrary web script or HTML via the searchfor search parameter.


[CNNVD]kPlaylist searchfor参数跨站脚本漏洞(CNNVD-200511-417)

        kPlaylist是一个多语言支持的基于PHP和MySQL的音乐流系统。
        kPlaylist 1.6 (build 400)及可能的其他版本存在跨站脚本漏洞,可让远程攻击者通过searchfor搜索参数注入任意Web脚本或HTML

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3841
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3841
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-417
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2551
(UNKNOWN)  VUPEN  ADV-2005-2551
http://www.osvdb.org/21069
(UNKNOWN)  OSVDB  21069
http://secunia.com/advisories/17689
(VENDOR_ADVISORY)  SECUNIA  17689
http://www.securityfocus.com/bid/15546
(UNKNOWN)  BID  15546
http://pridels0.blogspot.com/2005/11/kplaylist-xss-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/11/kplaylist-xss-vuln.html

- 漏洞信息

kPlaylist searchfor参数跨站脚本漏洞
中危 跨站脚本
2005-11-26 00:00:00 2005-11-28 00:00:00
远程  
        kPlaylist是一个多语言支持的基于PHP和MySQL的音乐流系统。
        kPlaylist 1.6 (build 400)及可能的其他版本存在跨站脚本漏洞,可让远程攻击者通过searchfor搜索参数注入任意Web脚本或HTML

- 公告与补丁

        暂无数据

- 漏洞信息

21069
kPlaylist searchfor Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

kPlaylist contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate "searchfor" variable upon submission to the kPlaylist script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-23 Unknow
2005-11-23 Unknow

- 解决方案

Upgrade to build 1.6 412 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站