发布时间 :2005-11-22 16:03:00
修订时间 :2011-03-07 21:27:05

[原文]Cross-site scripting (XSS) vulnerability in Google Mini Search Appliance, and possibly Google Search Appliance, allows remote attackers to inject arbitrary Javascript, and possibly other web script or HTML, via the proxystylesheet variable, which will be executed in the resulting error message.


        Google Mini 搜索工具(可能也包括Google 搜索工具)中存在跨站脚本漏洞,允许远程攻击者通过将在结果错误消息中被执行的proxystylesheet变量注入任意的Javascript和其它可能的Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/h:google:search_applianceGoogle Search Appliance
cpe:/h:google:mini_search_applianceGoogle Mini Search Appliance

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  15509
(PATCH)  OSVDB  20978
(UNKNOWN)  VUPEN  ADV-2005-2500
(VENDOR_ADVISORY)  BUGTRAQ  20051121 Google Search Appliance proxystylesheet Flaws

- 漏洞信息

中危 跨站脚本
2005-11-22 00:00:00 2005-11-29 00:00:00
        Google Mini 搜索工具(可能也包括Google 搜索工具)中存在跨站脚本漏洞,允许远程攻击者通过将在结果错误消息中被执行的proxystylesheet变量注入任意的Javascript和其它可能的Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Google Search Appliance proxystylesheet Error Message XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

The Google Search Appliance contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user input when returning with an error page. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-21 2005-06-10
2005-11-21 Unknow

- 解决方案

Upgrade to the version specified by Google advisory GA-2005-08-m, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者