CVE-2005-3751
CVSS4.3
发布时间 :2005-11-22 15:03:00
修订时间 :2008-09-05 16:55:11
NMCOP    

[原文]HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.


[CNNVD]Pound HTTP请求窃取漏洞(CNNVD-200511-323)

        Pound 是一个HTTP代理服务器。
        Pound 1.9.4之前版本中的HTTP请求窃取漏洞,可让远程攻击者通过相冲突的内容长度(Content-length)和传输编码(Transfer-encoding)头,使Web高速缓存中毒、绕过Web应用程序防火墙保护以及执行XSS攻击。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3751
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3751
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-323
(官方数据源) CNNVD

- 其它链接及资源

http://www.novell.com/linux/security/advisories/2006_05_19.html
(UNKNOWN)  SUSE  SUSE-SR:2006:011
http://www.gentoo.org/security/en/glsa/glsa-200606-05.xml
(UNKNOWN)  GENTOO  GLSA-200606-05
http://www.debian.org/security/2005/dsa-934
(UNKNOWN)  DEBIAN  DSA-934
http://www.apsis.ch/pound/pound_list/archive/2005/2005-10/1129827166000/index_html?fullMode=1#1129827166000
(UNKNOWN)  MLIST  [pound-list] 20051020 ANNOUNCE: Pound - reverse proxy and load balancer - v1.9.4
http://secunia.com/advisories/20510
(VENDOR_ADVISORY)  SECUNIA  20510
http://secunia.com/advisories/20215
(VENDOR_ADVISORY)  SECUNIA  20215
http://secunia.com/advisories/18381
(VENDOR_ADVISORY)  SECUNIA  18381
http://secunia.com/advisories/18367
(VENDOR_ADVISORY)  SECUNIA  18367

- 漏洞信息

Pound HTTP请求窃取漏洞
中危 未知
2005-11-22 00:00:00 2007-07-03 00:00:00
远程  
        Pound 是一个HTTP代理服务器。
        Pound 1.9.4之前版本中的HTTP请求窃取漏洞,可让远程攻击者通过相冲突的内容长度(Content-length)和传输编码(Transfer-encoding)头,使Web高速缓存中毒、绕过Web应用程序防火墙保护以及执行XSS攻击。

- 公告与补丁

        

- 漏洞信息 (F42936)

Debian Linux Security Advisory 934-1 (PacketStormID:F42936)
2006-01-10 00:00:00
Debian  debian.org
advisory,web,vulnerability
linux,debian
CVE-2005-1391,CVE-2005-3751
[点击下载]

Debian Security Advisory DSA 934-1 - Two vulnerabilities have been discovered in Pound, a reverse proxy and load balancer for HTTP.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 934-1                     security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
January 9, 2006                         http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : pound
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2005-1391 CVE-2005-3751
Debian Bug     : 307852

Two vulnerabilities have been discovered in Pound, a reverse proxy and
load balancer for HTTP. The Common Vulnerabilities and Exposures project
identifies the following problems:

   * CVE-2005-1391:
     Overly long HTTP Host: headers may trigger a buffer overflow in the
     add_port() function, which may lead to the execution of arbitrary
     code.

   * CVE-2005-3751:
     HTTP requests with conflicting Content-Length and Transfer-Encoding
     headers could lead to HTTP Request Smuggling Attack, which can be
     exploited to bypass packet filters or poison web caches.

The old stable distribution (woody) does not contain pound packages.

For the stable distribution (sarge) these problems have been fixed in
version 1.8.2-1sarge1

For the unstable distribution (sid) these problems have been fixed in
version 1.9.4-1

We recommend that you upgrade your pound package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1.dsc
      Size/MD5 checksum:      643 334d91f8800581281ab9c8bad5bbdbf4
    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1.diff.gz
      Size/MD5 checksum:    13242 9e404c899bfd5409610ed5f14345d341
    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2.orig.tar.gz
      Size/MD5 checksum:   140455 c9b0793bb4d57be2270093d79b13c019

  Alpha architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_alpha.deb
      Size/MD5 checksum:    73284 0458e20d63c3f5f5788afe7564a385da

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_amd64.deb
      Size/MD5 checksum:    68652 01ae48ac313a8e533f32eec2f6f7a62f

  ARM architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_arm.deb
      Size/MD5 checksum:    69072 73b7eb49a74c8a5ff6a8015cf9a0e45d

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_i386.deb
      Size/MD5 checksum:    68684 da43b8adaf115680c72d8f5dce9bc99f

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_ia64.deb
      Size/MD5 checksum:    80756 ec6d043c70e50e8ba492ef6a73a4cc18

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_hppa.deb
      Size/MD5 checksum:    70288 22fa75150b2253640667714cf6197567

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_m68k.deb
      Size/MD5 checksum:    65138 1de5e7b4492a51900e13f9a0f5decd18

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_mips.deb
      Size/MD5 checksum:    68586 3eb28320dc9229ee8cc08d2967e8ee9b

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_mipsel.deb
      Size/MD5 checksum:    68654 510807d792c96e8cc43edf72fcdcc243

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_powerpc.deb
      Size/MD5 checksum:    69218 d03e4cc71f99c2017a417cf8f073438c

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/p/pound/pound_1.8.2-1sarge1_s390.deb
      Size/MD5 checksum:    69268 dac44abdc98358ccc66c2c3f41bd0965


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iQCVAwUBQ8MoNA0hVr09l8FJAQKMfwP9E7TsZiw0kSO33AT8r90MM1vnjxyQCdeC
1V+ex7HDQqRy3UQyElIw/CZTaDjebPL2cWmuUTNBWn6QVQkwFOfB9Vf5EjZN0snO
7g9oLVNBAqnbXfwZK3vTXiEp7OewFhVysKvC8V1NG/I/W8lGKoFBt1ODNaJDUINb
vGORDYVP7fA=
=zxip
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/
    

- 漏洞信息

22298
Pound HTTP Request Smuggling
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-10-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.9.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站