CVE-2005-3737
CVSS5.1
发布时间 :2005-11-21 19:03:00
修订时间 :2011-03-07 21:27:03
NMCOPS    

[原文]Buffer overflow in the SVG importer (style.cpp) of inkscape 0.41 through 0.42.2 might allow remote attackers to execute arbitrary code via a SVG file with long CSS style property values.


[CNNVD]Inkscape SVG图像缓冲区溢出漏洞(CNNVD-200511-286)

        inkscape是一个开放原始码的向量绘图软件。
        inkscape 0.41至0.42.2的SVG导入程序(stylecpp)中的缓冲区溢出,可能让远程攻击者通过具有长CSS样式属性值的SVG文件执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:inkscape:inkscape:0.41inkscape 0.41
cpe:/a:inkscape:inkscape:0.42.1
cpe:/a:inkscape:inkscape:0.42.2inkscape 0.42.2
cpe:/a:inkscape:inkscape:0.42inkscape 0.42

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3737
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3737
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-286
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15507
(PATCH)  BID  15507
http://secunia.com/advisories/17662
(VENDOR_ADVISORY)  SECUNIA  17662
http://www.vupen.com/english/advisories/2005/2511
(UNKNOWN)  VUPEN  ADV-2005-2511
http://www.ubuntulinux.org/usn/usn-217-1
(UNKNOWN)  UBUNTU  USN-217-1
http://www.novell.com/linux/security/advisories/2005_28_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2005:028
http://www.gentoo.org/security/en/glsa/glsa-200511-22.xml
(UNKNOWN)  GENTOO  GLSA-200511-22
http://www.debian.org/security/2005/dsa-916
(UNKNOWN)  DEBIAN  DSA-916
http://secunia.com/advisories/17882
(UNKNOWN)  SECUNIA  17882
http://secunia.com/advisories/17778
(UNKNOWN)  SECUNIA  17778
http://secunia.com/advisories/17651
(VENDOR_ADVISORY)  SECUNIA  17651
http://cvs.sourceforge.net/viewcvs.py/inkscape/inkscape/src/style.cpp?r1=1.110&r2=1.110.2.1
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/inkscape/inkscape/src/style.cpp?r1=1.110&r2=1.110.2.1
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=330894
(UNKNOWN)  MISC  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=330894
http://securityreason.com/securityalert/58
(UNKNOWN)  SREASON  58

- 漏洞信息

Inkscape SVG图像缓冲区溢出漏洞
中危 缓冲区溢出
2005-11-21 00:00:00 2006-06-12 00:00:00
远程  
        inkscape是一个开放原始码的向量绘图软件。
        inkscape 0.41至0.42.2的SVG导入程序(stylecpp)中的缓冲区溢出,可能让远程攻击者通过具有长CSS样式属性值的SVG文件执行任意代码。
        

- 公告与补丁

        Ubuntu Linux已发布了USN-217-1安全公告来解决此问题。请参阅引用的公告了解更多信息。
        Gentoo已发布了GLSA 200511-22公告来解决此问题。作为超级用户运行下列命令可应用Gentoo更新:
        emerge --sync
        emerge --ask --oneshot --verbose ">=media-gfx/inkscape-0.43"
        SUSE公告SUSE-SR:2005:028可用于解决各种问题。请参阅引用的公告了解更多信息。
        Debian已发布了DSA 916-1公告来解决此问题。请参阅引用的公告了解更多信息。
        --
        目前我们尚不明确是否有任何供应商提供针对此问题的补丁程序。如果您发现我们有失误或者了解更新的信息,请给我们发邮件: vuldb@securityfocus.com

- 漏洞信息 (F42230)

Debian Linux Security Advisory 916-1 (PacketStormID:F42230)
2005-12-14 00:00:00
Debian  security.debian.org
advisory,overflow,arbitrary,shell,vulnerability
linux,debian
CVE-2005-3737,CVE-2005-3885
[点击下载]

Debian Security Advisory DSA 916-1 - Several vulnerabilities have been discovered in Inkscape, a vector-based drawing program. Joxean Koret discovered a buffer overflow in the SVG parsing routines that can lead to the execution of arbitrary code. Javier Fernandez-Sanguino Pena noticed that the ps2epsi extension shell script uses a hardcoded temporary file making it vulnerable to symlink attacks.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 916-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
December 7th, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : inkscape
Vulnerability  : buffer overflow
Problem type   : local (remote)
Debian-specific: no
CVE ID         : CVE-2005-3737 CVE-2005-3885
BugTraq ID     : 14522
Debian Bug     : 321501 330894

Several vulnerabilities have been discovered in Inkscape, a
vector-based drawing program.  The Common Vulnerabilities and
Exposures project identifies the following problems:

CVE-2005-3737

    Joxean Koret discovered a buffer overflow in the SVG parsing
    routines that can lead to the execution of arbitrary code.

CVE-2005-3885

    Javier Fern    

- 漏洞信息

21001
Inkspace SVG Importer Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-09-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Inkscape SVG Image Buffer Overflow Vulnerability
Boundary Condition Error 15507
Yes No
2005-11-21 12:00:00 2005-11-21 12:00:00
Joxean Koret is credited with the discovery of this vulnerability.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
Inkscape Inkscape 0.42
+ Gentoo Linux
Inkscape Inkscape 0.41
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

Inkscape is prone to a buffer overflow vulnerability. This issue is due to a failure in the application to do proper bounds checking on user-supplied data before copying it into a finite sized buffer.

When the application processes a malformed SVG image file, it results in a buffer overflow. An attacker can exploit this vulnerability to execute arbitrary code in the context of the victim user.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

The following denial of service proof of concept is available:

- 解决方案

Ubuntu Linux has released security advisory USN-217-1 addressing this issue. Please see the referenced advisory for further information.

Gentoo has released advisory GLSA 200511-22 to address this issue. Gentoo updates may be applied by running the following commands as the superuser:

emerge --sync
emerge --ask --oneshot --verbose ">=media-gfx/inkscape-0.43"

SUSE advisory SUSE-SR:2005:028 is available to address various issues. Please see the referenced advisory for more information.

Debian has released advisory DSA 916-1 to address this issue. Please see the referenced advisory for more information.

--
Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站