发布时间 :2005-11-18 20:03:00
修订时间 :2011-03-07 21:26:59

[原文]Cross-site scripting (XSS) vulnerability in shopadmin.asp in VP-ASP Shopping Cart 5.50 allows remote attackers to inject arbitrary web script or HTML via the UserName parameter.

[CNNVD]VP-ASP Shopping Cart Shopadmin.ASP 跨站脚本漏洞(CNNVD-200511-261)

        VP-ASP Shopping Cart是一款在线商店程序。
        VP-ASP Shopping Cart 5.50的shopadmin.asp存在跨站脚本(XSS)漏洞,可让远程攻击者通过UserName参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2005-2486
(UNKNOWN)  BID  15490

- 漏洞信息

VP-ASP Shopping Cart Shopadmin.ASP 跨站脚本漏洞
中危 跨站脚本
2005-11-18 00:00:00 2005-11-21 00:00:00
        VP-ASP Shopping Cart是一款在线商店程序。
        VP-ASP Shopping Cart 5.50的shopadmin.asp存在跨站脚本(XSS)漏洞,可让远程攻击者通过UserName参数注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

VP-ASP Shopping Cart shopadmin.asp UserName Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

VP-ASP Shopping Cart contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "UserName" variable upon submission to the shopadmin.asp script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-18 Unknow
2005-11-18 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

VP-ASP Shopping Cart Shopadmin.ASP HTML Injection Vulnerability
Input Validation Error 15490
Yes No
2005-11-17 12:00:00 2009-07-12 05:56:00
ConcorDHacK is credited with the discovery of this vulnerability.

- 受影响的程序版本

VP-ASP Shopping Cart

- 漏洞讨论

VP-ASP Shopping Cart is prone to an HTML injection vulnerability. This is due to a lack of proper validation of user-supplied input before being used in dynamically generated content.

Attacker-supplied HTML and script code would be executed in the context of the affected Web site, potentially allowing for theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

- 漏洞利用

No exploit is required.

Proof of concept code has been provided:

<TITLE>VP-ASP Shopping UserName HTML Injection Vulnerability</TITLE>
<form action= name=LoginForm method=POST>
<input type=hidden name=UserName value='"><script>alert("Vulnerable server!!!
By ConcorDHacK")</script>
<b><font color="red" size="10">Vulnerable server<br>By>
</font> </b>' /> <input type=hidden name=Password size="20" value="123"></td>
<input type=submit name="Login" value="GO ! GO !"><br><br><br>By ConcorDHacK<br>
<a href=""></a>

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考