CVE-2005-3648
CVSS7.5
发布时间 :2005-11-17 06:02:00
修订时间 :2016-10-17 23:36:39
NMCO    

[原文]Multiple SQL injection vulnerabilities in the get_record function in datalib.php in Moodle 1.5.2 allow remote attackers to execute arbitrary SQL commands via the id parameter in (1) category.php and (2) info.php.


[CNNVD]Moodle datalib.php多个SQL注入漏洞(CNNVD-200511-224)

        Moodle是一个课程管理系统。
        Moodle 1.5.2的datalib.php中get_record函数内的多个SQL注入漏洞,可让远程攻击者通过(1) category.php和(2) info.php中的id参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3648
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3648
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-224
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=113165668814241&w=2
(UNKNOWN)  BUGTRAQ  20051110 Moodle <=1.6dev blind SQL Injection
http://rgod.altervista.org/moodle16dev.html
(VENDOR_ADVISORY)  MISC  http://rgod.altervista.org/moodle16dev.html
http://securitytracker.com/id?1015181
(UNKNOWN)  SECTRACK  1015181
http://www.securityfocus.com/bid/15380/
(UNKNOWN)  BID  15380
http://www.vupen.com/english/advisories/2005/2387
(UNKNOWN)  VUPEN  ADV-2005-2387
http://xforce.iss.net/xforce/xfdb/23058
(UNKNOWN)  XF  moodle-multi-scripts-sql-injection(23058)

- 漏洞信息

Moodle datalib.php多个SQL注入漏洞
高危 SQL注入
2005-11-17 00:00:00 2005-11-17 00:00:00
远程  
        Moodle是一个课程管理系统。
        Moodle 1.5.2的datalib.php中get_record函数内的多个SQL注入漏洞,可让远程攻击者通过(1) category.php和(2) info.php中的id参数执行任意SQL命令。

- 公告与补丁

        暂无数据

- 漏洞信息

20748
Moodle datalib.php get_record() Function Multiple Script SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Moodle contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'get_record()' function in the datalib.php script not properly sanitizing user-supplied input to the 'id' variable in the category.php and info.php scripts. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-11-10 Unknow
2005-11-10 Unknow

- 解决方案

Upgrade to version 1.6dev or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站