CVE-2005-3646
CVSS7.5
发布时间 :2005-11-17 06:02:00
修订时间 :2016-10-17 23:36:37
NMCO    

[原文]Multiple SQL injection vulnerabilities in lib-sessions.inc.php in phpAdsNew and phpPgAds 2.0.6 and possibly earlier versions allow remote attackers to execute arbitrary SQL commands via the sessionID parameter in (1) logout.php and (2) index.php.


[CNNVD]inphpAdsNew和phpPgAds 多个SQL注入漏洞(CNNVD-200511-219)

        phpadsnew和phppgads是一款基于web的新闻和广告管理程序。
        inphpAdsNew和phpPgAds 2.0.6及可能的更早版本中lib-sessions.inc.php内的多个SQL注入漏洞,可让远程攻击者通过(1) logout.php和(2) index.php中的sessionID参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

cpe:/a:phpadsnew:phpadsnew:2_dev_2001-10-09
cpe:/a:phpadsnew:phpadsnew:2.0.4_pr1
cpe:/a:phpadsnew:phpadsnew:2.0.5
cpe:/a:phpadsnew:phpadsnew:2.0.6
cpe:/a:phppgads:phppgads:2.0.6
cpe:/a:phpadsnew:phpadsnew:2.0.7_rc1
cpe:/a:phpadsnew:phpadsnew:2.0_beta5
cpe:/a:phpadsnew:phpadsnew:2.0_beta6
cpe:/a:phpadsnew:phpadsnew:2_dev_2001-09-30

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3646
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3646
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-219
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=113165036315035&w=2
(UNKNOWN)  BUGTRAQ  20051110 [FS-05-01] Multiple vulnerabilities in phpAdsNew
http://seclists.org/lists/bugtraq/2005/Nov/0189.html
(UNKNOWN)  BUGTRAQ  20051115 [PHPADSNEW-SA-2005-002] phpAdsNew and phpPgAds 2.0.7 fix multiple vulnerabilities
http://securityreason.com/securityalert/171
(UNKNOWN)  SREASON  171
http://securityreason.com/securityalert/172
(UNKNOWN)  SREASON  172
http://securitytracker.com/id?1015193
(UNKNOWN)  SECTRACK  1015193
http://sourceforge.net/project/shownotes.php?group_id=36679&release_id=370942
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=36679&release_id=370942
http://www.fitsec.com/advisories/FS-05-01.txt
(VENDOR_ADVISORY)  MISC  http://www.fitsec.com/advisories/FS-05-01.txt
http://www.securityfocus.com/bid/15385/
(PATCH)  BID  15385
http://www.vupen.com/english/advisories/2005/2380
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2380
http://www.zone-h.org/en/advisories/read/id=8413/
(VENDOR_ADVISORY)  MISC  http://www.zone-h.org/en/advisories/read/id=8413/
http://xforce.iss.net/xforce/xfdb/23044
(UNKNOWN)  XF  phpadsnew-logout-sql-injection(23044)

- 漏洞信息

inphpAdsNew和phpPgAds 多个SQL注入漏洞
高危 SQL注入
2005-11-17 00:00:00 2006-06-12 00:00:00
远程  
        phpadsnew和phppgads是一款基于web的新闻和广告管理程序。
        inphpAdsNew和phpPgAds 2.0.6及可能的更早版本中lib-sessions.inc.php内的多个SQL注入漏洞,可让远程攻击者通过(1) logout.php和(2) index.php中的sessionID参数执行任意SQL命令。

- 公告与补丁

        

- 漏洞信息

20744
phpPgAds / phpAdsNew logout.php sessionID SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

phpAdsNew contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the logout.php script not properly sanitizing user-supplied input via the sessionID. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-11-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站