CVE-2005-3621
CVSS5.0
发布时间 :2005-11-16 06:02:00
修订时间 :2008-09-05 16:54:49
NMCOPS    

[原文]CRLF injection vulnerability in phpMyAdmin before 2.6.4-pl4 allows remote attackers to conduct HTTP response splitting attacks via unspecified scripts.


[CNNVD]phpMyAdmin CRLF注入漏洞(CNNVD-200511-204)

        phpMyAdmin是一种MySQL的管理工具。
        phpMyAdmin 2.6.4-pl4之前版本中的CRLF注入漏洞,可让远程攻击者通过未指定的脚本执行HTTP响应拆分攻击。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpmyadmin:phpmyadmin:2.2.7_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.6.4_pl3
cpe:/a:phpmyadmin:phpmyadmin:2.5.4
cpe:/a:phpmyadmin:phpmyadmin:2.5.3
cpe:/a:phpmyadmin:phpmyadmin:2.5.7_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.5.5_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.5.2_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.6.1_pl3
cpe:/a:phpmyadmin:phpmyadmin:2.2.0
cpe:/a:phpmyadmin:phpmyadmin:2.5.6_rc2
cpe:/a:phpmyadmin:phpmyadmin:2.6.2_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl3
cpe:/a:phpmyadmin:phpmyadmin:2.6.3_pl1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3621
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3621
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-204
(官方数据源) CNNVD

- 其它链接及资源

http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-6
(VENDOR_ADVISORY)  CONFIRM  http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-6
http://www.novell.com/linux/security/advisories/2005_28_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2005:028
http://www.debian.org/security/2006/dsa-1207
(UNKNOWN)  DEBIAN  DSA-1207
http://securitytracker.com/id?1015213
(UNKNOWN)  SECTRACK  1015213
http://secunia.com/advisories/22781
(UNKNOWN)  SECUNIA  22781
http://secunia.com/advisories/17578
(UNKNOWN)  SECUNIA  17578

- 漏洞信息

phpMyAdmin CRLF注入漏洞
中危 输入验证
2005-11-16 00:00:00 2005-11-16 00:00:00
远程  
        phpMyAdmin是一种MySQL的管理工具。
        phpMyAdmin 2.6.4-pl4之前版本中的CRLF注入漏洞,可让远程攻击者通过未指定的脚本执行HTTP响应拆分攻击。

- 公告与补丁

        暂无数据

- 漏洞信息 (F52337)

Debian Linux Security Advisory 1207-2 (PacketStormID:F52337)
2006-11-20 00:00:00
Debian  debian.org
advisory
linux,debian
CVE-2006-1678,CVE-2006-2418,CVE-2005-3621,CVE-2005-3665,CVE-2006-5116
[点击下载]

Debian Security Advisory 1207-2 - The phpmyadmin update in DSA 1207 introduced a regression. This update corrects this flaw.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1207-2                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
November 19th, 2006                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : phpmyadmin
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2006-1678 CVE-2006-2418 CVE-2005-3621 CVE-2005-3665 CVE-2006-5116
Debian Bug     : 339437 340438 362567 368082 391090

The phpmyadmin update in DSA 1207 introduced a regression. This update
corrects this flaw. For completeness, the original advisory text below:
 
Several remote vulnerabilities have been discovered in phpMyAdmin, a
program to administrate MySQL over the web. The Common Vulnerabilities
and Exposures project identifies the following problems:

CVE-2005-3621

    CRLF injection vulnerability allows remote attackers to conduct
    HTTP response splitting attacks.

CVE-2005-3665

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via the (1) HTTP_HOST
    variable and (2) various scripts in the libraries directory that
    handle header generation.

CVE-2006-1678

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via scripts in the
    themes directory.

CVE-2006-2418

    A cross-site scripting (XSS) vulnerability allows remote attackers
    to inject arbitrary web script or HTML via the db parameter of
    footer.inc.php.

CVE-2006-5116

    A remote attacker could overwrite internal variables through the
    _FILES global variable.

For the stable distribution (sarge) these problems have been fixed in
version 2.6.2-3sarge3.

For the upcoming stable release (etch) and unstable distribution (sid)
these problems have been fixed in version 2.9.0.3-1.

We recommend that you upgrade your phpmyadmin package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3.dsc
      Size/MD5 checksum:      604 32ee16f4370604bc150d93c5676fface
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3.diff.gz
      Size/MD5 checksum:    38520 f27c4b99bbdb3dc13fb71aef99749247
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2.orig.tar.gz
      Size/MD5 checksum:  2654418 05e33121984824c43d94450af3edf267

  Architecture independent components:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3_all.deb
      Size/MD5 checksum:  2769182 00f14fb52a14546e92ece84c16cd249f


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFYFPdXm3vHE4uyloRAgj5AJ4k0NXBlTZgTK+vJTlgPNTEBfeBGgCg61oX
s2aDzIfiBIc0hbLjIGOwEcQ=
=EQpq
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/
    

- 漏洞信息 (F51974)

Debian Linux Security Advisory 1207-1 (PacketStormID:F51974)
2006-11-13 00:00:00
Debian  debian.org
advisory,remote,vulnerability,xss
linux,debian
CVE-2006-1678,CVE-2006-2418,CVE-2005-3621,CVE-2005-3665,CVE-2006-5116
[点击下载]

Debian Security Advisory 1207-1 - Several remote vulnerabilities have been discovered in phpMyAdmin that allow for everything from CRLF injection to cross site scripting.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1207-1                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
November 9th, 2006                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : phpmyadmin
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2006-1678 CVE-2006-2418 CVE-2005-3621 CVE-2005-3665 CVE-2006-5116
Debian Bug     : 339437 340438 362567 368082 391090

Several remote vulnerabilities have been discovered in phpMyAdmin, a
program to administrate MySQL over the web. The Common Vulnerabilities
and Exposures project identifies the following problems:

CVE-2005-3621

    CRLF injection vulnerability allows remote attackers to conduct
    HTTP response splitting attacks.

CVE-2005-3665

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via the (1) HTTP_HOST
    variable and (2) various scripts in the libraries directory that
    handle header generation.

CVE-2006-1678

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via scripts in the
    themes directory.

CVE-2006-2418

    A cross-site scripting (XSS) vulnerability allows remote attackers
    to inject arbitrary web script or HTML via the db parameter of
    footer.inc.php.

CVE-2006-5116

    A remote attacker could overwrite internal variables through the
    _FILES global variable.

For the stable distribution (sarge) these problems have been fixed in
version 2.6.2-3sarge2.

For the upcoming stable release (etch) and unstable distribution (sid)
these problems have been fixed in version 2.9.0.3-1.

We recommend that you upgrade your phpmyadmin package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge2.dsc
      Size/MD5 checksum:      604 b650978a6bf3102a49350166d186335e
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge2.diff.gz
      Size/MD5 checksum:    37905 1d1a6528059d2e0420670e557935967b
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2.orig.tar.gz
      Size/MD5 checksum:  2654418 05e33121984824c43d94450af3edf267

  Architecture independent components:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge2_all.deb
      Size/MD5 checksum:  2768594 73c65fac24493138f7adb9fddf507d7a


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFU2yCXm3vHE4uyloRAvfHAJwPlDTYreoBSvD3eRnkNkbmluutpQCgmeEl
vc63gwSK1Evd77y3u8hqjkU=
=MNWJ
-----END PGP SIGNATURE-----

    

- 漏洞信息

20910
phpMyAdmin header_http.inc.php HTTP Response Splitting
Remote / Network Access

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-11-15 2005-11-12
Unknow Unknow

- 解决方案

Upgrade to version 2.6.4-pl4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHPMyAdmin Header_HTTP_Inc.PHP HTTP Response Splitting Vulnerability
Input Validation Error 15422
Yes No
2005-11-09 12:00:00 2007-01-12 10:30:00
Toni Koivunen is credited with the discovery of this vulnerability.

- 受影响的程序版本

SAP Web Application Server 7.0
SAP Web Application Server 6.40
SAP Web Application Server 6.20
SAP Web Application Server 6.10
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
phpMyAdmin phpMyAdmin 2.7 .0-beta1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

phpMyAdmin is prone to an HTTP-response-splitting vulnerability because the application fails to properly sanitize user-supplied input.

A remote attacker may exploit this vulnerability to influence or misrepresent web content is served, cached, or interpreted. This could aid in various attacks that attempt to entice client users into a false sense of trust.

This issue is reported to affect phpMyAdmin version 2.7.0-beta1; other versions may also be vulnerable.

- 漏洞利用

An exploit is not required.

- 解决方案

Please see the referenced advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站