CVE-2005-3588
CVSS7.5
发布时间 :2005-11-16 02:42:00
修订时间 :2016-10-17 23:36:20
NMCO    

[原文]SQL injection vulnerability in admin.php in Advanced Guestbook 2.2 allows remote attackers to execute arbitrary SQL commands and gain privileges via the username field.


[CNNVD]Advanced Guestbook admin.php SQL注入漏洞(CNNVD-200511-155)

        Advanced Guestbook是一款基于PHP的留言系统。
        Advanced Guestbook 2.2的admin.php中的SQL注入漏洞,可让远程攻击者通过用户名字段执行任意SQL命令并获得特权。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3588
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3588
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-155
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=113140938101756&w=2
(UNKNOWN)  BUGTRAQ  20051106 Advanced Guestbook 2.2 ( SQL Injection Exploit )
http://marc.info/?l=bugtraq&m=113477483705918&w=2
(UNKNOWN)  BUGTRAQ  20051216 exploit (html) for Advanced Guestbook 2.2
http://xforce.iss.net/xforce/xfdb/15892
(UNKNOWN)  XF  advancedguestbook-sql-injection(15892)

- 漏洞信息

Advanced Guestbook admin.php SQL注入漏洞
高危 SQL注入
2005-11-16 00:00:00 2005-11-23 00:00:00
远程  
        Advanced Guestbook是一款基于PHP的留言系统。
        Advanced Guestbook 2.2的admin.php中的SQL注入漏洞,可让远程攻击者通过用户名字段执行任意SQL命令并获得特权。

- 公告与补丁

        

- 漏洞信息

20952
Advanced Guestbook admin.php Username Field SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Advanced Guestbook contains a flaw that may allow a remote attacker to inject arbitrary SQL queries. The issue is due to the 'admin.php' script not properly sanitizing user-supplied input to the 'Username' field, which may allow a remote attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-11-06 Unknow
2005-11-06 Unknow

- 解决方案

Upgrade to version 2.3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站