CVE-2005-3581
CVSS7.2
发布时间 :2005-11-16 02:42:00
修订时间 :2011-03-07 21:26:48
NMCO    

[原文]GDAL before 1.3.0-r1 allows local users in the portage group to increase privileges via a shared object in the Portage temporary build directory, which is added to the search path allowing objects in it to be loaded at runtime.


[CNNVD]GDAL本地用户权限提升漏洞(CNNVD-200511-159)

        DAL(Geospatial Data Abstraction Library)是一个在X/MIT许可协议下的开源栅格空间数据转换库。
        GDAL 1.3.0-r1以前的版本,允许portage组中的本地用户通过在Portage临时目录中共享对象来提升权限,这会增加搜索路径以让该对象在运行被加载。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gdal:gdal:1.2.6_r2
cpe:/a:gdal:gdal:1.2.5_r1
cpe:/a:gdal:gdal:1.2.5
cpe:/a:gdal:gdal:1.3.0
cpe:/a:gdal:gdal:1.2.6_r3
cpe:/a:gdal:gdal:1.2.6_r1
cpe:/a:gdal:gdal:1.2.6_r4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3581
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3581
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-159
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200511-02.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200511-02
http://secunia.com/advisories/17427/
(VENDOR_ADVISORY)  SECUNIA  17427
http://www.vupen.com/english/advisories/2005/2281
(UNKNOWN)  VUPEN  ADV-2005-2281
http://www.securityfocus.com/bid/15120
(UNKNOWN)  BID  15120
http://www.osvdb.org/20529
(UNKNOWN)  OSVDB  20529

- 漏洞信息

GDAL本地用户权限提升漏洞
高危 设计错误
2005-11-16 00:00:00 2005-11-23 00:00:00
本地  
        DAL(Geospatial Data Abstraction Library)是一个在X/MIT许可协议下的开源栅格空间数据转换库。
        GDAL 1.3.0-r1以前的版本,允许portage组中的本地用户通过在Portage临时目录中共享对象来提升权限,这会增加搜索路径以让该对象在运行被加载。

- 公告与补丁

        暂无数据

- 漏洞信息

20529
GDAL RUNPATH Variable Local Privilege Escalation
Local Access Required
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2005-11-03 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.3.0-r1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站