CVE-2005-3570
CVSS4.3
发布时间 :2005-11-16 02:42:00
修订时间 :2011-05-19 00:00:00
NMCOPS    

[原文]Unspecified cross-site scripting (XSS) vulnerability in Horde before 2.2.9 allows remote attackers to inject arbitrary web script or HTML via "not properly escaped error messages".


[CNNVD]Horde未明的跨站脚本攻击漏洞(CNNVD-200511-187)

        Horde 是个以PHP为基础的架构,用于创建网络应用程序。
        Horde 2.2.9之前版本中未指定的跨站脚本(XSS)攻击漏洞,可让远程攻击者通过"未适当避免的错误消息"注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:horde:horde:2.2.1
cpe:/a:horde:horde:2.2.7
cpe:/a:horde:horde:2.2.6
cpe:/a:horde:horde:2.2.5
cpe:/a:horde:horde:2.2.4
cpe:/a:horde:horde:2.2.3
cpe:/a:horde:horde:2.2.8
cpe:/a:horde:horde:2.2
cpe:/a:horde:horde:2.2.4_rc1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3570
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3570
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-187
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15409
(PATCH)  BID  15409
http://www.gentoo.org/security/en/glsa/glsa-200511-20.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200511-20
http://www.debian.org/security/2005/dsa-914
(VENDOR_ADVISORY)  DEBIAN  DSA-914
http://secunia.com/advisories/17794
(VENDOR_ADVISORY)  SECUNIA  17794
http://secunia.com/advisories/17702
(VENDOR_ADVISORY)  SECUNIA  17702
http://secunia.com/advisories/17468
(VENDOR_ADVISORY)  SECUNIA  17468
http://cvs.horde.org/diff.php/horde/docs/CHANGES?r1=1.207.2.109&r2=1.207.2.111&ty=h
(PATCH)  CONFIRM  http://cvs.horde.org/diff.php/horde/docs/CHANGES?r1=1.207.2.109&r2=1.207.2.111&ty=h
http://www.vupen.com/english/advisories/2005/2403
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2403
http://lists.horde.org/archives/announce/2005/000231.html
(UNKNOWN)  MLIST  [Horde-announce] 20051113 Horde 2.2.9 (final)

- 漏洞信息

Horde未明的跨站脚本攻击漏洞
中危 跨站脚本
2005-11-16 00:00:00 2010-06-23 00:00:00
远程  
        Horde 是个以PHP为基础的架构,用于创建网络应用程序。
        Horde 2.2.9之前版本中未指定的跨站脚本(XSS)攻击漏洞,可让远程攻击者通过"未适当避免的错误消息"注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Horde Horde 2.2
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Horde 2.2.1
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Horde 2.2.3
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Horde 2.2.4 -RC1
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Horde 2.2.4
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Horde 2.2.5
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Horde 2.2.6
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Horde 2.2.7
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz
        Horde Project Horde 2.2.9
        ftp://ftp.horde.org/pub/horde/horde-2.2.9.tar.gz

- 漏洞信息 (F42025)

Debian Linux Security Advisory 914-1 (PacketStormID:F42025)
2005-12-02 00:00:00
Debian  security.debian.org
advisory,web
linux,debian
CVE-2005-3570
[点击下载]

Debian Security Advisory DSA 914-1 - A vulnerability has been discovered in horde2, a web application suite, that allows attackers to insert arbitary script code into the error web page.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 914-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
December 1st, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : horde2
Vulnerability  : missing input sanitising
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2005-3570
BugTraq ID     : 15409
Debian Bug     : 338983

A vulnerability has been discovered in horde2, a web application
suite, that allows attackers to insert arbitary script code into the
error web page.

The old stable distribution (woody) does not contain horde2 packages.

For the stable distribution (sarge) this problem has been fixed in
version 2.2.8-1sarge1.

For the unstable distribution (sid) this problem has been fixed in
version 2.2.9-1.

We recommend that you upgrade your horde2 package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8-1sarge1.dsc
      Size/MD5 checksum:      575 fc3d76af255dd93e839ed24cf7c3ba84
    http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8-1sarge1.diff.gz
      Size/MD5 checksum:    38308 d87c50a15c7133ba4ca29d99c77d5da1
    http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8.orig.tar.gz
      Size/MD5 checksum:   683005 89961af4e4488a908147d7b3a0dc3b44

  Architecture independent components:

    http://security.debian.org/pool/updates/main/h/horde2/horde2_2.2.8-1sarge1_all.deb
      Size/MD5 checksum:   721182 761d84ac7f89eef150fa21c8b0c79541


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDjsLFW5ql+IAeqTIRArczAJ9xrGplMhujM0krR4rgEkOda/8IIgCghoAY
vCeMSRKp4CS5d/bdWLvL+No=
=ZF1J
-----END PGP SIGNATURE-----

    

- 漏洞信息

20815
Horde lib/Horde.php getFormData() Function Error Message XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2005-11-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.2.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Horde Unspecified Error Message Cross-Site Scripting Vulnerability
Input Validation Error 15409
Yes No
2005-11-14 12:00:00 2006-04-13 05:17:00
This issue was reported by the vendor.

- 受影响的程序版本

Horde Project Horde 2.2.8
Horde Project Horde 2.2.7
Horde Project Horde 2.2.6
Horde Project Horde 2.2.5
Horde Project Horde 2.2.4 -RC1
Horde Project Horde 2.2.4
Horde Project Horde 2.2.3
Horde Project Horde 2.2.1
Horde Project Horde 2.2
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Horde Project Horde 2.2.9

- 不受影响的程序版本

Horde Project Horde 2.2.9

- 漏洞讨论

Horde is prone to an unspecified cross-site scripting vulnerability. This issue is related to how Horde renders error messages.

Successful exploitation could let an attacker inject hostile HTML and script code into the browser session of another user in the context of the site hosting Horde. This could allow the attacker to steal cookie-based authentication credentials or to launch other attacks.

- 漏洞利用

An exploit is not required.

- 解决方案


Horde 2.2.9 has been released to address this vulnerability.

Please see the referenced advisories for more information.


Horde Project Horde 2.2

Horde Project Horde 2.2.1

Horde Project Horde 2.2.3

Horde Project Horde 2.2.4 -RC1

Horde Project Horde 2.2.4

Horde Project Horde 2.2.5

Horde Project Horde 2.2.6

Horde Project Horde 2.2.7

Horde Project Horde 2.2.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站