CVE-2005-3553
CVSS7.5
发布时间 :2005-11-16 02:42:00
修订时间 :2011-09-06 00:00:00
NMCO    

[原文]Multiple SQL injection vulnerabilities in include.php in PHPKIT 1.6.1 R2 and earlier allow remote attackers to execute arbitrary SQL commands via the (1) id parameter in conjunction with the login/userinfo.php path and (2) the session parameter (aka the PHPKITSID variable).


[CNNVD]PHPKIT include.php多个SQL注入漏洞(CNNVD-200511-205)

        PHPKIT是一款基于WEB的消息论坛系统。
        PHPKIT 1.6.1 R2及更早版本的include.php中的多个SQL注入漏洞,可让远程攻击者通过(1) 与login/userinfo.php路径结合的id参数和(2)会话参数(也称为PHPKITSID变量)执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3553
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3553
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-205
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/23013
(UNKNOWN)  XF  phpkit-phpkitsid-sql-injection(23013)
http://xforce.iss.net/xforce/xfdb/23010
(UNKNOWN)  XF  phpkit-userinfo-sql-injection(23010)
http://www.vupen.com/english/advisories/2005/2344
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2344
http://www.securityfocus.com/bid/15354
(UNKNOWN)  BID  15354
http://www.osvdb.org/20561
(UNKNOWN)  OSVDB  20561
http://www.osvdb.org/20560
(UNKNOWN)  OSVDB  20560
http://www.hardened-php.net/advisory_212005.80.html
(VENDOR_ADVISORY)  MISC  http://www.hardened-php.net/advisory_212005.80.html
http://securitytracker.com/id?1015167
(UNKNOWN)  SECTRACK  1015167
http://secunia.com/advisories/17479
(UNKNOWN)  SECUNIA  17479
http://cert.uni-stuttgart.de/archive/bugtraq/2005/11/msg00110.html
(UNKNOWN)  BUGTRAQ  20051105 Advisory 21/2005: Multiple vulnerabilities in PHPKIT

- 漏洞信息

PHPKIT include.php多个SQL注入漏洞
高危 SQL注入
2005-11-16 00:00:00 2006-06-12 00:00:00
远程  
        PHPKIT是一款基于WEB的消息论坛系统。
        PHPKIT 1.6.1 R2及更早版本的include.php中的多个SQL注入漏洞,可让远程攻击者通过(1) 与login/userinfo.php路径结合的id参数和(2)会话参数(也称为PHPKITSID变量)执行任意SQL命令。

- 公告与补丁

        暂无数据

- 漏洞信息

20560
PHPKIT userinfo.php id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PHPKIT contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the userinfo.php script not properly sanitizing user-supplied input to the "id" variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-11-07 2005-09-30
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站