CVE-2005-3540
CVSS7.5
发布时间 :2005-12-31 00:00:00
修订时间 :2008-09-05 16:54:40
NMCOPS    

[原文]Buffer overflow in petris before 1.0.1 allows remote attackers to execute arbitrary code via unspecified attack vectors.


[CNNVD]Petris本地缓冲区溢出漏洞(CNNVD-200512-663)

        petris的1.0.1之前版本存在缓冲区溢出漏洞,远程攻击者可以通过一个未明的攻击向量来执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3540
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3540
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-663
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16190
(UNKNOWN)  BID  16190
http://www.debian.org/security/2005/dsa-929
(UNKNOWN)  DEBIAN  DSA-929
http://secunia.com/advisories/18384
(UNKNOWN)  SECUNIA  18384
http://secunia.com/advisories/18362
(UNKNOWN)  SECUNIA  18362

- 漏洞信息

Petris本地缓冲区溢出漏洞
高危 缓冲区溢出
2005-12-31 00:00:00 2006-01-11 00:00:00
本地  
        petris的1.0.1之前版本存在缓冲区溢出漏洞,远程攻击者可以通过一个未明的攻击向量来执行任意代码。

- 公告与补丁

        

- 漏洞信息 (F42923)

Debian Linux Security Advisory 929-1 (PacketStormID:F42923)
2006-01-10 00:00:00
Debian  debian.org
advisory,overflow,arbitrary
linux,debian
CVE-2005-3540
[点击下载]

Debian Security Advisory DSA 929-1 - Steve Kemp from the Debian Security Audit project discovered a buffer overflow in petris, a clone of the Tetris game, which may be exploited to execute arbitrary code with group games privileges.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 929-1                     security@debian.org
http://www.debian.org/security/                                 Steve Kemp
Jan 9, 2006                             http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Vulnerability  : buffer overflow
Problem-Type   : local
Debian-specific: no
CVE ID         : CVE-2005-3540

Steve Kemp from the Debian Security Audit project discovered a buffer
overflow in petris, a clone of the Tetris game, which may be exploited
to execute arbitary code with group games privileges.

The old stable distribution (woody) does not contain the petris package.

For the stable distribution (sarge) this problem has been fixed in
version 1.0.1-4sarge0.

For the unstable distribution the package will be updated shortly.

We recommend that you upgrade your petris package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    petris_1.0.1-4sarge0.diff.gz
      Size/MD5 checksum:     4255 f043952580a76a670090f5e10456cac0
    petris_1.0.1-4sarge0.dsc
      Size/MD5 checksum:      597 a8f7e7dc2da54370faf95307432ea057
    petris_1.0.1.orig.tar.gz
      Size/MD5 checksum:    11400 36ce4098c5305606ebbb66641eb9cea3

  Alpha architecture:

    petris_1.0.1-4sarge0_alpha.deb
      Size/MD5 checksum:    17164 14925ee0cd40732d78d4d3267e304a6d

  AMD64 architecture:

    petris_1.0.1-4sarge0_amd64.deb
      Size/MD5 checksum:    16118 ae80ded8db7237ac7ffbd235e94583bc

  ARM architecture:

    petris_1.0.1-4sarge0_arm.deb
      Size/MD5 checksum:    14808 710db3e851a54a5c385a691de161ec35

  HP Precision architecture:

    petris_1.0.1-4sarge0_hppa.deb
      Size/MD5 checksum:    16402 a7f392bda8179958a5cd95299865c1a5

  Intel IA-32 architecture:

    petris_1.0.1-4sarge0_i386.deb
      Size/MD5 checksum:    15040 2efc32faf40e7402e818a088ab2ba6e2

  Intel IA-64 architecture:

    petris_1.0.1-4sarge0_ia64.deb
      Size/MD5 checksum:    19610 bea0e1a48f9159ea1ef1c291af8f7974

  Motorola 680x0 architecture:

    petris_1.0.1-4sarge0_m68k.deb
      Size/MD5 checksum:    14342 84fd7e89e8034c491df081bf562047f5

  Big endian MIPS architecture:

    petris_1.0.1-4sarge0_mips.deb
      Size/MD5 checksum:    16488 4828a8700d380fe7fee578c4982cadc1

  Little endian MIPS architecture:

    petris_1.0.1-4sarge0_mipsel.deb
      Size/MD5 checksum:    16434 3da9a116a510b2d095076015494fc72c

  PowerPC architecture:

    petris_1.0.1-4sarge0_powerpc.deb
      Size/MD5 checksum:    17154 246d78ced212deb20bafdffc25b34503

  IBM S/390 architecture:

    petris_1.0.1-4sarge0_s390.deb
      Size/MD5 checksum:    15928 bafe7066921152a84e610268031b1c3b

  Sun Sparc architecture:

    petris_1.0.1-4sarge0_sparc.deb
      Size/MD5 checksum:    14866 e7a0d84f92bbf1e57d4aef61e257fc48

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iQCVAwUBQ8JnOw0hVr09l8FJAQIdbAP9H6Y5L5ITLAgT8bjjEHSCFsqSS6kOd/mO
KdZVK68xbIiMJCiB53T/RPHh3H6goeCJqKLpEGJTDDLCJtM0NW3hCQLduLS0MIrO
Za2nyL3GVz6STd156WUlvv4OEHSfCg8FqEc+3tOMR/0FrRvmWXJCqWoRtWHaFuha
cyC487hTGU0=
=8jF9
-----END PGP SIGNATURE-----

    

- 漏洞信息

22300
Petris Unspecified Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Petris Local Buffer Overflow Vulnerability
Boundary Condition Error 16190
No Yes
2006-01-09 12:00:00 2008-01-10 04:39:00
Discovered by Steve Kemp from the Debian Security Audit Project.

- 受影响的程序版本

Nortel Networks VPN Router 5000 1.0.1
KETM KETM 0.0.6
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

petris is vulnerable to a locally exploitable buffer overflow vulnerability. It has been reported that a local attacker may exploit this condition to execute attacker-supplied code with group games privileges.

Due to a lack of information, further details cannot be provided at the moment. This BID will be updated when more information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Debian Linux has released security advisory DSA 929-1 addressing this issue. Please see the referenced advisory for further information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站