CVE-2005-3538
CVSS7.5
发布时间 :2005-12-31 00:00:00
修订时间 :2011-03-07 21:26:45
NMCOPS    

[原文]hfaxd in HylaFAX 4.2.3, when PAM support is disabled, accepts arbitrary passwords, which allows remote attackers to gain privileges.


[CNNVD]HylaFAX Remote PAM认证绕过漏洞(CNNVD-200512-629)

        HylaFAX 4.2.3中的hfaxd,当禁用了PAM支持时,接受任意密码,因此,远程攻击者可以获取权限。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3538
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3538
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-629
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16150
(PATCH)  BID  16150
http://www.gentoo.org/security/en/glsa/glsa-200601-03.xml
(PATCH)  GENTOO  GLSA-200601-03
http://secunia.com/advisories/18337
(VENDOR_ADVISORY)  SECUNIA  18337
http://secunia.com/advisories/18314
(VENDOR_ADVISORY)  SECUNIA  18314
http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=719
(PATCH)  MISC  http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=719
http://www.vupen.com/english/advisories/2006/0072
(UNKNOWN)  VUPEN  ADV-2006-0072
http://www.securityfocus.com/archive/1/archive/1/420974/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060105 HylaFAX Security advisory - fixed in HylaFAX 4.2.4
http://www.hylafax.org/content/HylaFAX_4.2.4_release
(UNKNOWN)  CONFIRM  http://www.hylafax.org/content/HylaFAX_4.2.4_release
http://www.hylafax.org/archive/2005-12/msg00119.php
(UNKNOWN)  MLIST  [hylafax-users] 20051212 Re: proceedure for hylafax setup for PAM authentiation
http://www.mandriva.com/security/advisories?name=MDKSA-2006:015
(UNKNOWN)  MANDRIVA  MDKSA-2006:015
http://secunia.com/advisories/18489
(UNKNOWN)  SECUNIA  18489

- 漏洞信息

HylaFAX Remote PAM认证绕过漏洞
高危 设计错误
2005-12-31 00:00:00 2006-01-11 00:00:00
远程  
        HylaFAX 4.2.3中的hfaxd,当禁用了PAM支持时,接受任意密码,因此,远程攻击者可以获取权限。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        ftp://ftp.hylafax.org/source/hylafax-4.2.4.tar.gz

- 漏洞信息 (F42854)

HylaFAX-01042006.txt (PacketStormID:F42854)
2006-01-08 00:00:00
 
advisory,remote,arbitrary
CVE-2005-3538,CVE-2005-3539
[点击下载]

HylaFAX version 4.2.3 hfaxd will allow any password when compiled with PAM support disabled. Also, the HylaFAX notify script passes unsanitised user-supplied data to eval, allowing remote attackers to execute arbitrary commands. The data needs to be part of a submitted job and as such, attackers must have access to submit faxes to the server in order to exploit this vulnerability. HylaFAX versions 4.2.0 up to 4.2.3 are vulnerable.

I'm passing this on for Patrice Fournier who is not around today.
------------------------------------------------------------------------------

HylaFAX security advisory
4 Jan 2006

Subject:  HylaFAX hfaxd and notify/faxrcvd vulnerabilities

Introduction:

HylaFAX is a mature (est. 1991) enterprise-class open-source software
package for sending and receiving facsimiles as well as for sending
alpha-numeric pages.  It runs on a wide variety of UNIX-like platforms
including Linux, BSD (including Mac OS X), SunOS and Solaris, SCO, IRIX,
AIX, and HP-UX.  See http://www.hylafax.org


Problem Descriptions and Impact:

1. HylaFAX hfaxd will allow any password when compiled with PAM support
disabled.

Only HylaFAX version 4.2.3 is vulnerable. 

This vulnerability was mentioned by Dileep <dileep@networkgulf.com>
on the hylafax-users mailing list on December 12, was picked up and 
confirmed by Lee Horward and a fix was provided the same day by Todd
Lipcon. The fix was committed to CVS-HEAD on December 15.

This hfaxd PAM vulnerability has been assigned CVE-2005-3538

2. HylaFAX notify script passes unsanitised user-supplied data to eval,
allowing remote attackers to execute arbitrary commands. The data needs to be
part of a submitted job and as such, attackers must have access to submit faxes
to the server in order to exploit this vulnerability.

HylaFAX versions 4.2.0 up to 4.2.3 are vulnerable. Prior version used
a awk notify script that was not vulnerable. This vulnerability was
discovered and fixed by Patrice Fournier of iFAX Solutions, Inc.

HylaFAX faxrcvd script also passes unsanitised user-supplied data to eval,
allowing remote attackers to execute arbitrary commands. CallID 
(CIDName/CIDNumber) must be configured on the server and the attackers
must have access to submit non alphanumeric characters as CallID data
(which may not be possible for most configuration) in order to exploit
this vulnerability.

HylaFAX versions 4.2.2 and 4.2.3 are vulnerable. Prior version didn't support a
variable number of CallID parameters. These vulnerabilities were discovered and
fixed by Patrice Fournier of iFAX Solutions, Inc. The fix was committed to
CVS-HEAD on January 4.

These script vulnerabilities have been assigned CVE-2005-3539


Status:

HylaFAX.org has released HylaFAX version 4.2.4 which includes changes
to fix each of these problems.  All HylaFAX users are strongly
encouraged to upgrade.  The HylaFAX 4.2.4 source code is available at

   ftp://ftp.hylafax.org/source/hylafax-4.2.4.tar.gz

In the event that upgrading to 4.2.4 is not appropriate, the patches to
fix those vulnerabilities are available at the following bug reports:

   http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=682
   http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=719

If PAM support is NOT enabled and upgrading or patching is not possible,
firewalling techniques restricting access to port 4559 are strongly
encouraged. As the patches to faxrcvd and notify are simple changes to
shell scripts, you should apply those patches in either case.

No abuse of these vulnerabilities is known to HylaFAX development.

Thanks,

The vendor-sec mailing list was notified on 21st December, and HylaFAX
CVS-HEAD was updated on 15 December for the PAM-disabled login
vulnerability and on 4 January for the other two vulnerabilities.

Patrice Fournier
HylaFAX developer
    

- 漏洞信息

22245
HylaFAX hfaxd with PAM Password Policy Bypass
Authentication Management
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.2.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

HylaFAX Remote PAM Authentication Bypass Vulnerability
Design Error 16150
Yes No
2006-01-05 12:00:00 2006-08-11 09:10:00
Dileep <dileep@networkgulf.com> reported this issue to the vendor.

- 受影响的程序版本

Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
Mandriva Linux Mandrake 10.2 x86_64
Mandriva Linux Mandrake 10.2
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Hylafax Hylafax 4.2.3
Gentoo Linux
Hylafax Hylafax 4.2.4

- 不受影响的程序版本

Hylafax Hylafax 4.2.4

- 漏洞讨论

The HylaFAX daemon is reported prone to a vulnerability that could allow unauthorized access to the HylaFAX service. Reportedly, the issue presents itself due to a flaw in its PAM (Pluggable Authentication Modules) usage.

A remote attacker may exploit this vulnerability to gain unauthorized access to the affected service.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released an advisory along with HylaFAX version 4.2.4 to address this issue.

Please see the referenced advisories for more information.


Hylafax Hylafax 4.2.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站