CVE-2005-3536
CVSS7.5
发布时间 :2005-12-22 18:03:00
修订时间 :2008-09-05 16:54:39
NMCO    

[原文]SQL injection vulnerability in phpBB 2 before 2.0.18 allows remote attackers to execute arbitrary SQL commands via the topic type.


[CNNVD]PHPBB多个未明漏洞(CNNVD-200512-560)

        phpBB 2在2.0.18之前版本存在SQL注入漏洞,远程攻击者可以通过topic类型执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.0
cpe:/a:phpbb_group:phpbb:2.0_beta1
cpe:/a:phpbb_group:phpbb:2.0.6c
cpe:/a:phpbb_group:phpbb:2.0.17
cpe:/a:phpbb_group:phpbb:2.0.6
cpe:/a:phpbb_group:phpbb:2.0.9
cpe:/a:phpbb_group:phpbb:2.0.12
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0.6d
cpe:/a:phpbb_group:phpbb:2.0_rc4
cpe:/a:phpbb_group:phpbb:2.0.7a
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.16
cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.14
cpe:/a:phpbb_group:phpbb:2.0.10
cpe:/a:phpbb_group:phpbb:2.0_rc3
cpe:/a:phpbb_group:phpbb:2.0.7
cpe:/a:phpbb_group:phpbb:2.0_rc1
cpe:/a:phpbb_group:phpbb:2.0.8
cpe:/a:phpbb_group:phpbb:2.0.8a
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.13
cpe:/a:phpbb_group:phpbb:2.0.11
cpe:/a:phpbb_group:phpbb:2.0.15
cpe:/a:phpbb_group:phpbb:2.0_rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3536
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3536
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-560
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15246
(PATCH)  BID  15246
http://www.debian.org/security/2005/dsa-925
(VENDOR_ADVISORY)  DEBIAN  DSA-925
http://www.osvdb.org/22270
(UNKNOWN)  OSVDB  22270
http://secunia.com/advisories/18098
(UNKNOWN)  SECUNIA  18098

- 漏洞信息

PHPBB多个未明漏洞
高危 SQL注入
2005-12-22 00:00:00 2005-12-27 00:00:00
远程  
        phpBB 2在2.0.18之前版本存在SQL注入漏洞,远程攻击者可以通过topic类型执行任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.phpbb.com/files/releases/phpbb_2.0.17_to_2.0.18.zip

- 漏洞信息

22270
phpBB topic type SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

phpBB contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the not properly sanitizing user-supplied input to the 'topic type'. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.18 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站