发布时间 :2005-11-22 19:03:00
修订时间 :2011-03-07 21:26:43

[原文]fusermount in FUSE before 2.4.1, if installed setuid root, allows local users to corrupt /etc/mtab and possibly modify mount options by performing a mount over a directory whose name contains certain special characters.


        FUSE 2.4.1之前版本中的fusermount,在安装了setuid root时,可让本地用户通过对名称包含某些特殊字符的目录执行安装,以此来毁坏/etc/mtab并可能修改安装选项。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  15529
(UNKNOWN)  VUPEN  ADV-2005-2529

- 漏洞信息

低危 输入验证
2005-11-22 00:00:00 2005-11-29 00:00:00
        FUSE 2.4.1之前版本中的fusermount,在安装了setuid root时,可让本地用户通过对名称包含某些特殊字符的目录执行安装,以此来毁坏/etc/mtab并可能修改安装选项。

- 公告与补丁


- 漏洞信息

FUSE fusermount Crafted Mountpoint mtab Corruption DoS
Denial of Service
Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-11-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.4.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

FUSE Mount Options Corruption Vulnerability
Input Validation Error 15529
No Yes
2005-11-22 12:00:00 2006-04-10 05:27:00
Thomas Biege is credited with the discovery of this vulnerability. This issue was disclosed in the referenced Gentoo advisory.

- 受影响的程序版本

Miklos Szeredi FUSE 2.4 .0
Miklos Szeredi FUSE 2.3 .0
Miklos Szeredi FUSE 2.3 -rc1
Miklos Szeredi FUSE 2.2.1
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
Miklos Szeredi FUSE 2.2
Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
Gentoo Linux

- 漏洞讨论

FUSE is prone to a vulnerability that could change or corrupt current mount options.

Successful exploitation could result in a denial of service if mount options become unusable. An attacker can also exploit this issue to add arbitrary mount points that could grant the attacker read access (and possibly write access) to otherwise restricted or privileged mount points. Other attacks are also possible.

- 漏洞利用

No exploit is required.

- 解决方案

Please see the referenced advisories for further information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

Miklos Szeredi FUSE 2.3 .0

- 相关参考