CVE-2005-3518
CVSS7.5
发布时间 :2005-11-06 06:02:00
修订时间 :2016-10-17 23:36:04
NMCO    

[原文]SQL injection vulnerability in search.php in PunBB 1.2.7 and 1.2.8 allows remote attackers to execute arbitrary SQL commands via the old_searches parameter.


[CNNVD]PunBB Search.PHP SQL注入漏洞(CNNVD-200511-139)

        PunBB是一个快速,轻量级PHP论坛系统。
        PunBB 1.2.7和1.2.8的search.php中的SQL注入漏洞,可让远程攻击者通过old_searches参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:punbb:punbb:1.2.7
cpe:/a:punbb:punbb:1.2.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3518
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3518
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-139
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112939699128430&w=2
(UNKNOWN)  BUGTRAQ  20051014 [KAPDA::#6] Punbb SQL Injection Vulnerability
http://securityreason.com/securityalert/87
(UNKNOWN)  SREASON  87
http://www.kapda.ir/advisory-91.html
(VENDOR_ADVISORY)  MISC  http://www.kapda.ir/advisory-91.html
http://www.punbb.org/changelogs/1.2.8_to_1.2.9.txt
(UNKNOWN)  CONFIRM  http://www.punbb.org/changelogs/1.2.8_to_1.2.9.txt
http://www.securityfocus.net/bid/15114/
(PATCH)  BID  15114
http://xforce.iss.net/xforce/xfdb/22760
(PATCH)  XF  punbb-oldsearches-sql-injection(22760)

- 漏洞信息

PunBB Search.PHP SQL注入漏洞
高危 SQL注入
2005-11-06 00:00:00 2005-11-08 00:00:00
远程  
        PunBB是一个快速,轻量级PHP论坛系统。
        PunBB 1.2.7和1.2.8的search.php中的SQL注入漏洞,可让远程攻击者通过old_searches参数执行任意SQL命令。

- 公告与补丁

        暂无数据

- 漏洞信息

20018
PunBB search.php old_searches Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

PunBB contains a flaw that may allow a remote attacker to carry out an SQL injection attack. The issue is due to the 'search.php' script not properly sanitizing user-supplied input to the 'old_searches' variable. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-10-14 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站