CVE-2005-3505
CVSS4.3
发布时间 :2005-11-05 06:02:00
修订时间 :2011-03-07 21:26:37
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the Entropy Chat script in cPanel 10.2.0-R82 and 10.6.0-R137 allows remote attackers to inject arbitrary web script or HTML via a chat message containing Javascript in style attributes in tags such as <b>, which are processed by Internet Explorer.


[CNNVD]cPanel Entropy Chat script 跨站脚本漏洞(CNNVD-200511-124)

        cPanel是功能强大,容易使用的虚拟主机控制系统。
        cPanel 10.2.0-R82和10.6.0-R137的Entropy Chat脚本中的跨站脚本攻击(XSS)漏洞,可让远程攻击者在聊天消息样式属性的等标记中包含Javascript(通过 Internet Explorer处理),以此注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cpanel:cpanel:10.2.0_r82
cpe:/a:cpanel:cpanel:10.6.0_r137

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3505
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3505
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-124
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2306
(UNKNOWN)  VUPEN  ADV-2005-2306
http://www.securityfocus.com/bid/15327
(UNKNOWN)  BID  15327
http://www.securityfocus.com/archive/1/archive/1/415722/30/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051104 Secunia Research: cPanel Entropy Chat Script Insertion Vulnerability
http://www.osvdb.org/20459
(UNKNOWN)  OSVDB  20459
http://securitytracker.com/id?1015157
(UNKNOWN)  SECTRACK  1015157
http://secunia.com/secunia_research/2005-56/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2005-56/advisory/
http://secunia.com/advisories/16609
(VENDOR_ADVISORY)  SECUNIA  16609
http://archives.neohapsis.com/archives/fulldisclosure/2005-11/0124.html
(VENDOR_ADVISORY)  FULLDISC  20051104 Secunia Research: cPanel Entropy Chat Script Insertion Vulnerability
http://securityreason.com/securityalert/148
(UNKNOWN)  SREASON  148

- 漏洞信息

cPanel Entropy Chat script 跨站脚本漏洞
中危 跨站脚本
2005-11-05 00:00:00 2006-06-14 00:00:00
远程  
        cPanel是功能强大,容易使用的虚拟主机控制系统。
        cPanel 10.2.0-R82和10.6.0-R137的Entropy Chat脚本中的跨站脚本攻击(XSS)漏洞,可让远程攻击者在聊天消息样式属性的等标记中包含Javascript(通过 Internet Explorer处理),以此注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

20459
cPanel Entropy Chat Message Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

cPanel contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate input passed in the message field upon submission to the Entropy Chat script. This could allow a user to create a specially crafted chat message that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-04 2005-10-10
2005-11-04 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站