CVE-2005-3419
CVSS7.5
发布时间 :2005-11-01 16:02:00
修订时间 :2016-10-17 23:35:26
NMCO    

[原文]SQL injection vulnerability in usercp_register.php in phpBB 2.0.17 allows remote attackers to execute arbitrary SQL commands via the signature_bbcode_uid parameter, which is not properly initialized.


[CNNVD]phpBB usercp_register.php SQL注入漏洞(CNNVD-200511-045)

        phpBB 2是一个论坛软件,使用PHP语言开发的并开放其原始码。
        phpBB 2.0.17的usercp_register.php中的SQL注入漏洞,可让远程攻击者通过未适当初始化的signature_bbcode_uid参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.12
cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.11
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.10
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.0
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0.7a
cpe:/a:phpbb_group:phpbb:2.0.16
cpe:/a:phpbb_group:phpbb:2.0.8
cpe:/a:phpbb_group:phpbb:2.0.15
cpe:/a:phpbb_group:phpbb:2.0.9
cpe:/a:phpbb_group:phpbb:2.0.14
cpe:/a:phpbb_group:phpbb:2.0.6
cpe:/a:phpbb_group:phpbb:2.0.13
cpe:/a:phpbb_group:phpbb:2.0.7
cpe:/a:phpbb_group:phpbb:2.0_rc1
cpe:/a:phpbb_group:phpbb:2.0_rc2
cpe:/a:phpbb_group:phpbb:2.0.6d
cpe:/a:phpbb_group:phpbb:2.0_rc3
cpe:/a:phpbb_group:phpbb:2.0.6c
cpe:/a:phpbb_group:phpbb:2.0_rc4
cpe:/a:phpbb_group:phpbb:2.0.8a
cpe:/a:phpbb_group:phpbb:2.0_beta1
cpe:/a:phpbb_group:phpbb:2.0.17

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3419
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3419
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-045
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=113081113317600&w=2
(UNKNOWN)  BUGTRAQ  20051031 Advisory 17/2005: phpBB Multiple Vulnerabilities
http://securityreason.com/securityalert/130
(UNKNOWN)  SREASON  130
http://securitytracker.com/id?1015121
(VENDOR_ADVISORY)  SECTRACK  1015121
http://www.debian.org/security/2005/dsa-925
(UNKNOWN)  DEBIAN  DSA-925
http://www.hardened-php.net/advisory_172005.75.html
(VENDOR_ADVISORY)  MISC  http://www.hardened-php.net/advisory_172005.75.html
http://www.securityfocus.com/bid/15243
(PATCH)  BID  15243
http://www.vupen.com/english/advisories/2005/2250
(UNKNOWN)  VUPEN  ADV-2005-2250

- 漏洞信息

phpBB usercp_register.php SQL注入漏洞
高危 SQL注入
2005-11-01 00:00:00 2005-11-15 00:00:00
远程  
        phpBB 2是一个论坛软件,使用PHP语言开发的并开放其原始码。
        phpBB 2.0.17的usercp_register.php中的SQL注入漏洞,可让远程攻击者通过未适当初始化的signature_bbcode_uid参数执行任意SQL命令。

- 公告与补丁

        暂无数据

- 漏洞信息

20390
phpBB usercp_register.php signature_bbcode_uid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

phpBB contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'usercp_register.php' script not properly sanitizing user-supplied input to the 'signature_bbcode_uid' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-10-31 2005-08-14
2005-10-31 Unknow

- 解决方案

Upgrade to version 2.0.18 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站