CVE-2005-3418
CVSS4.3
发布时间 :2005-11-01 16:02:00
修订时间 :2016-10-17 23:35:25
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) error_msg parameter to usercp_register.php, (2) forward_page parameter to login.php, and (3) list_cat parameter to search.php, which are not initialized as variables.


[CNNVD]phpBB 多个跨站脚本攻击(XSS)漏洞(CNNVD-200511-037)

        phpBB 2是一个论坛软件,使用PHP语言开发的并开放其原始码。
        phpBB 2.0.17及更早版本中的多个跨站脚本攻击(XSS)漏洞,可让远程攻击者通过并未初始化为变量的(1) usercp_register.php的error_msg参数、(2) login.php的forward_page参数和(3) search.php的list_cat参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.12
cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.11
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.10
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.0
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0.7a
cpe:/a:phpbb_group:phpbb:2.0.16
cpe:/a:phpbb_group:phpbb:2.0.8
cpe:/a:phpbb_group:phpbb:2.0.15
cpe:/a:phpbb_group:phpbb:2.0.9
cpe:/a:phpbb_group:phpbb:2.0.14
cpe:/a:phpbb_group:phpbb:2.0.6
cpe:/a:phpbb_group:phpbb:2.0.13
cpe:/a:phpbb_group:phpbb:2.0.7
cpe:/a:phpbb_group:phpbb:2.0_rc1
cpe:/a:phpbb_group:phpbb:2.0_rc2
cpe:/a:phpbb_group:phpbb:2.0.6d
cpe:/a:phpbb_group:phpbb:2.0_rc3
cpe:/a:phpbb_group:phpbb:2.0.6c
cpe:/a:phpbb_group:phpbb:2.0_rc4
cpe:/a:phpbb_group:phpbb:2.0.8a
cpe:/a:phpbb_group:phpbb:2.0_beta1
cpe:/a:phpbb_group:phpbb:2.0.17

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3418
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3418
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-037
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=113081113317600&w=2
(UNKNOWN)  BUGTRAQ  20051031 Advisory 17/2005: phpBB Multiple Vulnerabilities
http://securityreason.com/securityalert/130
(UNKNOWN)  SREASON  130
http://securitytracker.com/id?1015121
(VENDOR_ADVISORY)  SECTRACK  1015121
http://www.debian.org/security/2005/dsa-925
(UNKNOWN)  DEBIAN  DSA-925
http://www.hardened-php.net/advisory_172005.75.html
(VENDOR_ADVISORY)  MISC  http://www.hardened-php.net/advisory_172005.75.html
http://www.securityfocus.com/bid/15243
(PATCH)  BID  15243
http://www.vupen.com/english/advisories/2005/2250
(UNKNOWN)  VUPEN  ADV-2005-2250

- 漏洞信息

phpBB 多个跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2005-11-01 00:00:00 2005-11-15 00:00:00
远程  
        phpBB 2是一个论坛软件,使用PHP语言开发的并开放其原始码。
        phpBB 2.0.17及更早版本中的多个跨站脚本攻击(XSS)漏洞,可让远程攻击者通过并未初始化为变量的(1) usercp_register.php的error_msg参数、(2) login.php的forward_page参数和(3) search.php的list_cat参数来注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

20387
phpBB usercp_register.php error_msg Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'error_msg' variables upon submission to the 'usercp_register.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-10-31 2005-08-14
Unknow Unknow

- 解决方案

Upgrade to version 2.0.18 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站