CVE-2005-3406
CVSS4.3
发布时间 :2005-11-01 07:47:00
修订时间 :2011-03-07 21:26:29
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in phpESP 1.7.5 and earlier allows remote attackers to inject arbitrary web script or HTML via unknown vectors.


[CNNVD]phpESP跨站脚本漏洞(CNNVD-200511-043)

        phpESP是一款让非技术背景的使用者自行建立调查、管理、收集成果与观看统计资料的工具软件。
        phpESP 1.7.5及更早版本中的跨站脚本攻击(XSS)漏洞,可让远程攻击者通过未知矢量注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:butterfat:phpesp:1.7.5
cpe:/a:butterfat:phpesp:1.4_beta2
cpe:/a:butterfat:phpesp:1.6_rc2
cpe:/a:butterfat:phpesp:1.5_final
cpe:/a:butterfat:phpesp:1.7.1
cpe:/a:butterfat:phpesp:1.6_final
cpe:/a:butterfat:phpesp:1.6_rc1
cpe:/a:butterfat:phpesp:1.4_beta3
cpe:/a:butterfat:phpesp:1.7.2
cpe:/a:butterfat:phpesp:1.6_rc3
cpe:/a:butterfat:phpesp:1.5_rc1
cpe:/a:butterfat:phpesp:1.7_rc1
cpe:/a:butterfat:phpesp:1.7.5_dev3
cpe:/a:butterfat:phpesp:1.3_final
cpe:/a:butterfat:phpesp:1.7
cpe:/a:butterfat:phpesp:1.4_final
cpe:/a:butterfat:phpesp:1.5_rc2
cpe:/a:butterfat:phpesp:1.4_beta1
cpe:/a:butterfat:phpesp:1.7.5_dev2
cpe:/a:butterfat:phpesp:1.5_rc3
cpe:/a:butterfat:phpesp:1.6.1_final
cpe:/a:butterfat:phpesp:1.7_dev
cpe:/a:butterfat:phpesp:1.7.5_dev1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3406
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3406
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-043
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/22904
(PATCH)  XF  phpesp-unknown-xss(22904)
http://www.osvdb.org/20357
(PATCH)  OSVDB  20357
http://www.vupen.com/english/advisories/2005/2237
(UNKNOWN)  VUPEN  ADV-2005-2237
http://cvs.sourceforge.net/viewcvs.py/phpesp/phpESP/docs/CHANGES?rev=.&content-type=text/plain
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpesp/phpESP/docs/CHANGES?rev=.&content-type=text/plain
http://www.securityfocus.com/bid/15232
(UNKNOWN)  BID  15232
http://secunia.com/advisories/17333
(UNKNOWN)  SECUNIA  17333

- 漏洞信息

phpESP跨站脚本漏洞
中危 跨站脚本
2005-11-01 00:00:00 2005-11-15 00:00:00
远程  
        phpESP是一款让非技术背景的使用者自行建立调查、管理、收集成果与观看统计资料的工具软件。
        phpESP 1.7.5及更早版本中的跨站脚本攻击(XSS)漏洞,可让远程攻击者通过未知矢量注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        phpESP phpESP 1.7.5 -dev
        phpESP phpESP-1.8-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpesp/phpESP-1.8-rc1.tar.gz
        phpESP phpESP 1.7.5
        phpESP phpESP-1.8-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpesp/phpESP-1.8-rc1.tar.gz
        phpESP phpESP 1.7.5 -dev2
        phpESP phpESP-1.8-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpesp/phpESP-1.8-rc1.tar.gz
        phpESP phpESP 1.7.5 -dev3
        phpESP phpESP-1.8-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpesp/phpESP-1.8-rc1.tar.gz

- 漏洞信息

20357
phpESP Multiple Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

phpESP contains multiple flaws that allows a remote cross site scripting attack. No further details have been provided.

- 时间线

2005-10-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.8-rc1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站