CVE-2005-3387
CVSS4.6
发布时间 :2005-11-01 07:47:00
修订时间 :2011-03-07 21:26:27
NMCO    

[原文]The startup script in packages/RedHat/ntop.init in ntop before 3.2, when ntop.conf is writable by users besides root, creates temporary files insecurely, which allows remote attackers to execute arbitrary code.


[CNNVD]Ntop ntop.init不安全临时文件创建漏洞(CNNVD-200511-021)

        ntop 是一个用来实时监视网络使用情况的工具。
        ntop 3.2之前版本的程序包/RedHat/ntop.init中的启动脚本,在ntop.conf可由非root用户写入时,会创建不安全的临时文件,这可让远程攻击者执行任意代码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3387
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3387
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-021
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15242
(PATCH)  BID  15242
http://secunia.com/advisories/17382
(VENDOR_ADVISORY)  SECUNIA  17382
http://www.vupen.com/english/advisories/2005/2251
(UNKNOWN)  VUPEN  ADV-2005-2251
http://listgateway.unipi.it/pipermail/ntop-dev/2005-March/005296.html
(VENDOR_ADVISORY)  MLIST  [Ntop-dev] 20050331 Minor security issue w/ ntop.init (RedHat Packages directory)

- 漏洞信息

Ntop ntop.init不安全临时文件创建漏洞
中危 设计错误
2005-11-01 00:00:00 2005-11-15 00:00:00
本地  
        ntop 是一个用来实时监视网络使用情况的工具。
        ntop 3.2之前版本的程序包/RedHat/ntop.init中的启动脚本,在ntop.conf可由非root用户写入时,会创建不安全的临时文件,这可让远程攻击者执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Luca Deri ntop 3.1
        Luca Deri ntop-3.2.tgz
        http://prdownloads.sourceforge.net/ntop/ntop-3.2.tgz?download

- 漏洞信息

20401
Network Top (ntop) ntop.init Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-10-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站