发布时间 :2005-11-18 17:03:00
修订时间 :2011-10-18 00:00:00

[原文]Directory traversal vulnerability in GNU Gnump3d before 2.9.8 has unknown impact via "CGI parameters, and cookie values".

[CNNVD]GNU gnump3d CGI和Cookie参数目录遍历漏洞(CNNVD-200511-274)

        GNUMP3d 是一款小巧易用的流体服务器。
        GNU Gnump3d 2.9.8之前版本中的目录遍历漏洞通过"CGI参数和cookie值"具有未知的影响。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)

cpe:/a:gnu:gnump3d:2.9.3GNU GNUMP3D 2.9.3
cpe:/a:gnu:gnump3d:2.9.2GNU GNUMP3D 2.9.2
cpe:/a:gnu:gnump3d:2.9.7GNU GNUMP3D 2.9.7
cpe:/a:gnu:gnump3d:2.9GNU GNUMP3D 2.9
cpe:/a:gnu:gnump3d:2.9.5GNU GNUMP3D 2.9.5
cpe:/a:gnu:gnump3d:2.9.6GNU GNUMP3D 2.9.6
cpe:/a:gnu:gnump3d:2.9.1GNU GNUMP3D 2.9.1
cpe:/a:gnu:gnump3d:2.9.4GNU GNUMP3D 2.9.4

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  15496
(PATCH)  GENTOO  GLSA-200511-16

- 漏洞信息

GNU gnump3d CGI和Cookie参数目录遍历漏洞
中危 路径遍历
2005-11-18 00:00:00 2006-06-12 00:00:00
        GNUMP3d 是一款小巧易用的流体服务器。
        GNU Gnump3d 2.9.8之前版本中的目录遍历漏洞通过"CGI参数和cookie值"具有未知的影响。

- 公告与补丁


- 漏洞信息 (F41710)

Debian Linux Security Advisory 901-1 (PacketStormID:F41710)
2005-11-20 00:00:00

Debian Security Advisory DSA 901-1 - Several vulnerabilities have been discovered in gnump3d, a streaming server for MP3 and OGG files.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 901-1                                        Martin Schulze
November 19th, 2005           
- --------------------------------------------------------------------------

Package        : gnump3d
Vulnerability  : programming error
Problem type   : remote
Debian-specific: no
CVE IDs        : CVE-2005-3349 CVE-2005-3355

Several vulnerabilities have been discovered in gnump3d, a streaming
server for MP3 and OGG files.  The Common Vulnerabilities and
Exposures Project identifies the following problems:


    Ludwig Nussel discovered several temporary files that are created
    with predictable filenames in an insecure fashion and allows local
    attackers to craft symlink attacks.


    Ludwig Nussel discovered that the theme parameter to HTTP
    requests may be used for path traversal.

The old stable distribution (woody) does not contain a gnump3d package.

For the stable distribution (sarge) these problems have been fixed in
version 2.9.3-1sarge3.

For the unstable distribution (sid) these problems have been fixed in
version 2.9.8-1.

We recommend that you upgrade your gnump3 package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:
      Size/MD5 checksum:      575 49b982ffa8bc0981063c22e43e37d8e0
      Size/MD5 checksum:    16233 c719d2a258db442db1523c8f5c06560c
      Size/MD5 checksum:   616250 1a0d6a10f6ac2354e1f8c6000665f299

  Architecture independent components:
      Size/MD5 checksum:   603396 87d0c50400f7cd2d96e4c42982102f7e

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.4.2 (GNU/Linux)



- 漏洞信息

GNUMP3d Cookie Value Unspecified Traversal
Input Manipulation
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-11-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.9.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GNU gnump3d CGI And Cookie Parameter Directory Traversal Vulnerability
Input Validation Error 15496
Yes No
2005-11-18 12:00:00 2006-03-17 06:15:00
This issue was disclosed by the vendor.

- 受影响的程序版本

SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
GNU gnump3d 2.9.7
+ Gentoo Linux
GNU gnump3d 2.9.6
GNU gnump3d 2.9.5
+ Gentoo Linux
GNU gnump3d 2.9.4
GNU gnump3d 2.9.3
GNU gnump3d 2.9.2
GNU gnump3d 2.9.1
GNU gnump3d 2.9
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
GNU gnump3d 2.9.8

- 不受影响的程序版本

GNU gnump3d 2.9.8

- 漏洞讨论

GNU gnump3d is prone to a directory-traversal vulnerability.

Very little information is available on this issue. Presumably, an attacker can exploit this vulnerability to retrieve or corrupt arbitrary files. This may aid in further attacks against the underlying system; other attacks are also possible.

- 漏洞利用

No exploit is required.

- 解决方案

Please see the referenced advisories for further information.

The vendor has addressed this issue in gnump3d version 2.9.8.

GNU gnump3d 2.9

GNU gnump3d 2.9.1

GNU gnump3d 2.9.2

GNU gnump3d 2.9.3

GNU gnump3d 2.9.4

GNU gnump3d 2.9.5

GNU gnump3d 2.9.6

GNU gnump3d 2.9.7

- 相关参考