CVE-2005-3355
CVSS6.4
发布时间 :2005-11-18 17:03:00
修订时间 :2011-10-18 00:00:00
NMCOPS    

[原文]Directory traversal vulnerability in GNU Gnump3d before 2.9.8 has unknown impact via "CGI parameters, and cookie values".


[CNNVD]GNU gnump3d CGI和Cookie参数目录遍历漏洞(CNNVD-200511-274)

        GNUMP3d 是一款小巧易用的流体服务器。
        GNU Gnump3d 2.9.8之前版本中的目录遍历漏洞通过"CGI参数和cookie值"具有未知的影响。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)

cpe:/a:gnu:gnump3d:2.9.3GNU GNUMP3D 2.9.3
cpe:/a:gnu:gnump3d:2.9.2GNU GNUMP3D 2.9.2
cpe:/a:gnu:gnump3d:2.9.7GNU GNUMP3D 2.9.7
cpe:/a:gnu:gnump3d:2.9GNU GNUMP3D 2.9
cpe:/a:gnu:gnump3d:2.9.5GNU GNUMP3D 2.9.5
cpe:/a:gnu:gnump3d:2.9.6GNU GNUMP3D 2.9.6
cpe:/a:gnu:gnump3d:2.9.1GNU GNUMP3D 2.9.1
cpe:/a:gnu:gnump3d:2.9.4GNU GNUMP3D 2.9.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3355
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3355
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-274
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15496
(PATCH)  BID  15496
http://www.novell.com/linux/security/advisories/2005_28_sr.html
(VENDOR_ADVISORY)  SUSE  SUSE-SR:2005:028
http://www.gentoo.org/security/en/glsa/glsa-200511-16.xml
(PATCH)  GENTOO  GLSA-200511-16
http://www.debian.org/security/2005/dsa-901
(PATCH)  DEBIAN  DSA-901
http://secunia.com/advisories/17656
(VENDOR_ADVISORY)  SECUNIA  17656
http://secunia.com/advisories/17647
(VENDOR_ADVISORY)  SECUNIA  17647
http://secunia.com/advisories/17646
(VENDOR_ADVISORY)  SECUNIA  17646
http://www.vupen.com/english/advisories/2005/2489
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2489
http://www.gnu.org/software/gnump3d/ChangeLog
(UNKNOWN)  CONFIRM  http://www.gnu.org/software/gnump3d/ChangeLog

- 漏洞信息

GNU gnump3d CGI和Cookie参数目录遍历漏洞
中危 路径遍历
2005-11-18 00:00:00 2006-06-12 00:00:00
远程  
        GNUMP3d 是一款小巧易用的流体服务器。
        GNU Gnump3d 2.9.8之前版本中的目录遍历漏洞通过"CGI参数和cookie值"具有未知的影响。

- 公告与补丁

        暂无数据

- 漏洞信息 (F41710)

Debian Linux Security Advisory 901-1 (PacketStormID:F41710)
2005-11-20 00:00:00
Debian  security.debian.org
advisory,vulnerability
linux,debian
CVE-2005-3349,CVE-2005-3355
[点击下载]

Debian Security Advisory DSA 901-1 - Several vulnerabilities have been discovered in gnump3d, a streaming server for MP3 and OGG files.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 901-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
November 19th, 2005                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : gnump3d
Vulnerability  : programming error
Problem type   : remote
Debian-specific: no
CVE IDs        : CVE-2005-3349 CVE-2005-3355

Several vulnerabilities have been discovered in gnump3d, a streaming
server for MP3 and OGG files.  The Common Vulnerabilities and
Exposures Project identifies the following problems:

CVE-2005-3349

    Ludwig Nussel discovered several temporary files that are created
    with predictable filenames in an insecure fashion and allows local
    attackers to craft symlink attacks.

CVE-2005-3355

    Ludwig Nussel discovered that the theme parameter to HTTP
    requests may be used for path traversal.

The old stable distribution (woody) does not contain a gnump3d package.

For the stable distribution (sarge) these problems have been fixed in
version 2.9.3-1sarge3.

For the unstable distribution (sid) these problems have been fixed in
version 2.9.8-1.

We recommend that you upgrade your gnump3 package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge3.dsc
      Size/MD5 checksum:      575 49b982ffa8bc0981063c22e43e37d8e0
    http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge3.diff.gz
      Size/MD5 checksum:    16233 c719d2a258db442db1523c8f5c06560c
    http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3.orig.tar.gz
      Size/MD5 checksum:   616250 1a0d6a10f6ac2354e1f8c6000665f299

  Architecture independent components:

    http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge3_all.deb
      Size/MD5 checksum:   603396 87d0c50400f7cd2d96e4c42982102f7e


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDftFUW5ql+IAeqTIRAvsTAJ0UBLkVAUo4NSQg8r3MsbMtXGC0CgCfcvA0
wR5CC4V9G2kyiBDF9UsYWXE=
=/EV6
-----END PGP SIGNATURE-----

    

- 漏洞信息

20940
GNUMP3d Cookie Value Unspecified Traversal
Input Manipulation
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-11-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.9.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GNU gnump3d CGI And Cookie Parameter Directory Traversal Vulnerability
Input Validation Error 15496
Yes No
2005-11-18 12:00:00 2006-03-17 06:15:00
This issue was disclosed by the vendor.

- 受影响的程序版本

SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
GNU gnump3d 2.9.7
+ Gentoo Linux
GNU gnump3d 2.9.6
GNU gnump3d 2.9.5
+ Gentoo Linux
GNU gnump3d 2.9.4
GNU gnump3d 2.9.3
GNU gnump3d 2.9.2
GNU gnump3d 2.9.1
GNU gnump3d 2.9
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
GNU gnump3d 2.9.8

- 不受影响的程序版本

GNU gnump3d 2.9.8

- 漏洞讨论

GNU gnump3d is prone to a directory-traversal vulnerability.

Very little information is available on this issue. Presumably, an attacker can exploit this vulnerability to retrieve or corrupt arbitrary files. This may aid in further attacks against the underlying system; other attacks are also possible.

- 漏洞利用

No exploit is required.

- 解决方案


Please see the referenced advisories for further information.

The vendor has addressed this issue in gnump3d version 2.9.8.


GNU gnump3d 2.9

GNU gnump3d 2.9.1

GNU gnump3d 2.9.2

GNU gnump3d 2.9.3

GNU gnump3d 2.9.4

GNU gnump3d 2.9.5

GNU gnump3d 2.9.6

GNU gnump3d 2.9.7

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站