CVE-2005-3354
CVSS5.1
发布时间 :2005-11-20 16:03:00
修订时间 :2011-03-07 00:00:00
NMCOPS    

[原文]Stack-based buffer overflow in the ldif_get_line function in ldif.c of Sylpheed before 2.1.6 allows user-assisted attackers to execute arbitrary code by having local users import LDIF files with long lines.


[CNNVD]Sylpheed LDIF导入远程溢出漏洞(CNNVD-200511-283)

        Sylpheed是一款简单易用的轻型邮件客户端。
        Sylpheed的ldif.c中"ldif_get_line()"函数在处理畸形LDIF文件时存在栈溢出漏洞。如果攻击者能够诱骗用户向地址簿中导入特别创建的LDIF文件的话,就可以远程执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:sylpheed:sylpheed:2.0.2
cpe:/a:sylpheed:sylpheed:0.8.11
cpe:/a:sylpheed:sylpheed:1.0.2
cpe:/a:sylpheed:sylpheed:1.0.0
cpe:/a:sylpheed:sylpheed:2.1
cpe:/a:sylpheed:sylpheed:2.1.5
cpe:/a:sylpheed:sylpheed:2.1.1
cpe:/a:sylpheed:sylpheed:0.9.9
cpe:/a:sylpheed:sylpheed:2.0
cpe:/a:sylpheed:sylpheed:0.9.7
cpe:/a:sylpheed:sylpheed:2.0.1
cpe:/a:sylpheed:sylpheed:1.0.4
cpe:/a:sylpheed:sylpheed:0.9.6
cpe:/a:sylpheed:sylpheed:2.1.4
cpe:/a:sylpheed:sylpheed:2.0.3
cpe:/a:sylpheed:sylpheed:2.1.3
cpe:/a:sylpheed:sylpheed:0.9.11
cpe:/a:sylpheed:sylpheed:0.9.4
cpe:/a:sylpheed:sylpheed:1.0.3
cpe:/a:sylpheed:sylpheed:0.9.10
cpe:/a:sylpheed:sylpheed:1.0.1
cpe:/a:sylpheed:sylpheed:0.9.5
cpe:/a:sylpheed:sylpheed:0.9.8
cpe:/a:sylpheed:sylpheed:0.9.12
cpe:/a:sylpheed:sylpheed:2.1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3354
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3354
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200511-283
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200511-13.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200511-13
http://xforce.iss.net/xforce/xfdb/23028
(UNKNOWN)  XF  sylpheed-ldif-dos(23028)
http://www.xatrix.org/advisory.php?s=7282
(UNKNOWN)  FEDORA  FEDORA-2005-1063
http://www.vupen.com/english/advisories/2005/2360
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2360
http://www.securityfocus.com/bid/15363
(UNKNOWN)  BID  15363
http://www.novell.com/linux/security/advisories/2005_28_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2005:028
http://www.debian.org/security/2005/dsa-906
(UNKNOWN)  DEBIAN  DSA-906
http://sylpheed.good-day.net/en/news.html
(UNKNOWN)  CONFIRM  http://sylpheed.good-day.net/en/news.html
http://secunia.com/advisories/17831/
(VENDOR_ADVISORY)  SECUNIA  17831
http://secunia.com/advisories/17678
(VENDOR_ADVISORY)  SECUNIA  17678
http://secunia.com/advisories/17540/
(VENDOR_ADVISORY)  SECUNIA  17540
http://secunia.com/advisories/17525/
(VENDOR_ADVISORY)  SECUNIA  17525
http://secunia.com/advisories/17492
(VENDOR_ADVISORY)  SECUNIA  17492
http://osvdb.org/20675
(UNKNOWN)  OSVDB  20675

- 漏洞信息

Sylpheed LDIF导入远程溢出漏洞
中危 缓冲区溢出
2005-11-20 00:00:00 2006-08-28 00:00:00
远程  
        Sylpheed是一款简单易用的轻型邮件客户端。
        Sylpheed的ldif.c中"ldif_get_line()"函数在处理畸形LDIF文件时存在栈溢出漏洞。如果攻击者能够诱骗用户向地址簿中导入特别创建的LDIF文件的话,就可以远程执行任意代码。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://sylpheed.good-day.net/sylpheed/v1.0/sylpheed-1.0.6.tar.gz
        http://sylpheed.good-day.net/sylpheed/v2.0/sylpheed-2.0.4.tar.gz

- 漏洞信息 (F42870)

Ubuntu Security Notice 237-1 (PacketStormID:F42870)
2006-01-08 00:00:00
Ubuntu  security.ubuntu.com
advisory,remote,arbitrary,root
linux,ubuntu
CVE-2005-3354
[点击下载]

Ubuntu Security Notice USN-237-1 - Kurt Fitzner discovered that the NBD (network block device) server did not correctly verify the maximum size of request packets. By sending specially crafted large request packets, a remote attacker who is allowed to access the server could exploit this to execute arbitrary code with root privileges.

===========================================================
Ubuntu Security Notice USN-237-1	   January 06, 2006
nbd vulnerability
CVE-2005-3354
===========================================================

A security issue affects the following Ubuntu releases:

Ubuntu 5.10 (Breezy Badger)

The following packages are affected:

nbd-server

The problem can be corrected by upgrading the affected package to
version 1:2.7.4-1ubuntu0.1.  In general, a standard system upgrade is
sufficient to effect the necessary changes.

Details follow:

Kurt Fitzner discovered that the NBD (network block device) server did
not correctly verify the maximum size of request packets. By sending
specially crafted large request packets, a remote attacker who is
allowed to access the server could exploit this to execute arbitrary
code with root privileges.

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd_2.7.4-1ubuntu0.1.diff.gz
      Size/MD5:    33658 9681548b7c1a6382eae974202817d7b9
    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd_2.7.4-1ubuntu0.1.dsc
      Size/MD5:      588 29acf0d03aae92f01ad55faf0bc315e4
    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd_2.7.4.orig.tar.gz
      Size/MD5:   131430 841999f8d7ae0d6a903a6285ff68a49e

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd-client_2.7.4-1ubuntu0.1_amd64.deb
      Size/MD5:    22292 dd1283e9e72c3e468a8395ac4e4ee5f9
    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd-server_2.7.4-1ubuntu0.1_amd64.deb
      Size/MD5:    29780 3e33c37166bb012f07233bafbd8dcfc2

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd-client_2.7.4-1ubuntu0.1_i386.deb
      Size/MD5:    22306 224ebd247235d85b13d127c4a14e1d8e
    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd-server_2.7.4-1ubuntu0.1_i386.deb
      Size/MD5:    30020 ec25105a117d294f401f751fccf31737

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd-client_2.7.4-1ubuntu0.1_powerpc.deb
      Size/MD5:    22298 0efb5b981bbc2d62e67b8c8fef322e56
    http://security.ubuntu.com/ubuntu/pool/main/n/nbd/nbd-server_2.7.4-1ubuntu0.1_powerpc.deb
      Size/MD5:    31996 a4ace5d1280fab68a6fc0c93bc4fccc0
    

- 漏洞信息

20675
Sylpheed Address Book LDIF Import Overflow
Local Access Required Input Manipulation
Loss of Integrity Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

A flaw exists in the handling of importing LDIF files into the address book portion of Sylpheed. The flaw is triggered when a single line exceeds 2048 characters, and a stack-based overflow occurs. With a specially crafted file, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-11-08 Unknow
Unknow Unknow

- 解决方案

Upgrade to Sylpheed 2.1.6, Sylpheed-Claws 1.9.100 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Sylpheed LDIF Import Remote Buffer Overflow Vulnerability
Boundary Condition Error 15363
Yes No
2005-11-08 12:00:00 2006-03-20 06:09:00
Reported by the vendor.

- 受影响的程序版本

Sylpheed sylpheed-claws 1.0.4
Sylpheed sylpheed-claws 0.7.4
Sylpheed Sylpheed 2.0.3
+ Gentoo Linux
Sylpheed Sylpheed 2.0.2
Sylpheed Sylpheed 2.0.1
Sylpheed Sylpheed 2.0
Sylpheed Sylpheed 1.0.5
Sylpheed Sylpheed 1.0.4
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
Sylpheed Sylpheed 1.0.3
+ Gentoo Linux 1.4 _rc3
+ Gentoo Linux 1.4 _rc2
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.4
Sylpheed Sylpheed 1.0.2
Sylpheed Sylpheed 1.0.1
Sylpheed Sylpheed 1.0 .0
+ Turbolinux Home
+ Turbolinux Turbolinux Desktop 10.0
+ Turbolinux Turbolinux Server 10.0
+ Turbolinux Turbolinux Server 8.0
+ Turbolinux Turbolinux Server 7.0
+ Turbolinux Turbolinux Workstation 8.0
+ Turbolinux Turbolinux Workstation 7.0
Sylpheed Sylpheed 0.7.4
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
Red Hat Fedora Core3
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
Conectiva Linux 10.0
Sylpheed Sylpheed 2.0.4
Sylpheed Sylpheed 1.0.6

- 不受影响的程序版本

Sylpheed Sylpheed 2.0.4
Sylpheed Sylpheed 1.0.6

- 漏洞讨论

Sylpheed is prone to a buffer-overflow vulnerability.

A buffer overflow can occur when an unsuspecting user imports a malicious LFID file into an address book.

Exploitation of this vulnerability may allow an attacker to gain unauthorized access to the computer in the context of the Sylpheed client.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案


The vendor has released upgrades to address this issue.

Please see the referenced advisories for more information.


Sylpheed Sylpheed 0.7.4

Sylpheed Sylpheed 1.0 .0

Sylpheed Sylpheed 1.0.1

Sylpheed Sylpheed 1.0.2

Sylpheed Sylpheed 1.0.3

Sylpheed Sylpheed 1.0.4

Sylpheed Sylpheed 1.0.5

Sylpheed Sylpheed 2.0

Sylpheed Sylpheed 2.0.1

Sylpheed Sylpheed 2.0.2

Sylpheed Sylpheed 2.0.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站