CVE-2005-3343
CVSS4.6
发布时间 :2005-12-27 18:03:00
修订时间 :2010-04-02 01:56:28
NMCOS    

[原文]tkdiff before 4.1.1 allows local users to overwrite arbitrary files via a symlink attack on temporary files.


[CNNVD]TkDiff不安全临时文件创建漏洞(CNNVD-200512-569)

        tkdiff的4.1.1之前版本使得本地用户可以通过对临时文件发起symlink攻击来重写任意文件。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:tkdiff:tkdiff:4.1
cpe:/a:tkdiff:tkdiff:4.0.2
cpe:/a:tkdiff:tkdiff:3.0.8
cpe:/a:tkdiff:tkdiff:4.0
cpe:/a:tkdiff:tkdiff:3.0.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3343
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3343
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-569
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16064
(PATCH)  BID  16064
http://www.osvdb.org/21933
(PATCH)  OSVDB  21933
http://www.debian.org/security/2005/dsa-927
(PATCH)  DEBIAN  DSA-927
http://secunia.com/advisories/18083
(VENDOR_ADVISORY)  SECUNIA  18083
http://sourceforge.net/project/shownotes.php?release_id=380030&group_id=64960
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=380030&group_id=64960
http://secunia.com/advisories/18215
(UNKNOWN)  SECUNIA  18215
http://xforce.iss.net/xforce/xfdb/23858
(UNKNOWN)  XF  tkdiff-tmp-file-symlink(23858)
http://www.mandriva.com/security/advisories?name=MDKSA-2006:001
(UNKNOWN)  MANDRIVA  MDKSA-2006:001
http://securitytracker.com/id?1015421
(UNKNOWN)  SECTRACK  1015421

- 漏洞信息

TkDiff不安全临时文件创建漏洞
中危 设计错误
2005-12-27 00:00:00 2005-12-28 00:00:00
本地  
        tkdiff的4.1.1之前版本使得本地用户可以通过对临时文件发起symlink攻击来重写任意文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08-3woody0_all.deb
        http://freshmeat.net/redir/tkdiff/10603/url_tgz/tkdiff_4_1_1.tar.gz
        http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2-1sarge0_all.deb

- 漏洞信息

21933
TkDiff Temporary File Symlink Privilege Escalation
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

TkDiff contains a flaw that may allow a malicious local user to overwrite arbitrary files on the system. The issue is due to the TkDiff creating temporary files insecurely. It is possible for a user to use a symlink style attack to manipulate arbitrary files, resulting in a loss of integrity.

- 时间线

2005-12-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

TkDiff Insecure Temporary File Creation Vulnerability
Design Error 16064
No Yes
2005-12-27 12:00:00 2006-05-18 07:53:00
Discovered by Javier Fernandez-Sanguino Pena.

- 受影响的程序版本

TkDiff TkDiff 4.1
TkDiff TkDiff 4.0.2
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
TkDiff TkDiff 4.0
TkDiff TkDiff 3.0.9
TkDiff TkDiff 3.0.8
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
TkCVS TkCVS 7.2.2
Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
Mandriva Linux Mandrake 10.2 x86_64
Mandriva Linux Mandrake 10.2
TkDiff TkDiff 4.1.1

- 不受影响的程序版本

TkDiff TkDiff 4.1.1

- 漏洞讨论

TkDiff creates temporary files in an insecure manner.

Exploitation would most likely result in loss of data or a denial of service if critical files are overwritten in the attack. Other attacks may be possible as well.

TkDiff 4.1 and prior versions are vulnerable to this issue.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released TkDiff 4.1.1 to address this issue.

Please see the referenced advisories for more information.


TkDiff TkDiff 3.0.8

TkDiff TkDiff 3.0.9

TkDiff TkDiff 4.0

TkDiff TkDiff 4.0.2

TkDiff TkDiff 4.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站