发布时间 :2005-12-31 00:00:00
修订时间 :2011-03-07 21:26:20

[原文]The script in Tux Paint (tuxpaint) 0.9.14 and earlier creates temporary files insecurely, with unknown impact and attack vectors.

[CNNVD]Tux Paint不安全临时文件创建漏洞(CNNVD-200512-704)

        Tux Paint (tuxpaint) 0.9.14及更早版本的tuxpaint-import.sh脚本不安全地创建临时文件,具有未知影响和攻击向量。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  OSVDB  22453
(UNKNOWN)  VUPEN  ADV-2006-0193
(UNKNOWN)  XF  tuxpaint-tmpfile-symlink(24128)
(UNKNOWN)  BID  16250

- 漏洞信息

Tux Paint不安全临时文件创建漏洞
高危 设计错误
2005-12-31 00:00:00 2006-01-19 00:00:00
        Tux Paint (tuxpaint) 0.9.14及更早版本的tuxpaint-import.sh脚本不安全地创建临时文件,具有未知影响和攻击向量。

- 公告与补丁


- 漏洞信息 (F43248)

Debian Linux Security Advisory 941-1 (PacketStormID:F43248)
2006-01-21 00:00:00

Debian Security Advisory DSA 941-1 - The Debian Security Audit project discovered that a script in tuxpaint, a paint program for young children, creates a temporary file in an insecure fashion.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 941-1                                        Martin Schulze
January 16th, 2006            
- --------------------------------------------------------------------------

Package        : tuxpaint
Vulnerability  : insecure temporary file
Problem type   : local
Debian-specific: no
CVE ID         : CVE-2005-3340

Javier Fern    

- 漏洞信息

Tux Paint Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown

- 漏洞描述

Tux Paint contains a flaw that may allow a malicious local user to overwrite or create arbitrary files on the system. The issue is due to the script creating temporary files insecurely. It is possible for a user to use a symlink style attack to manipulate arbitrary files, resulting in a loss of integrity.

- 时间线

2006-01-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.15 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. Ubuntu users may upgrade to version 1:0.9.14-2ubuntu0.1. Debian users may upgrade to version 0.9.14-2sarge0.

- 相关参考

- 漏洞作者

- 漏洞信息

Tux Paint Insecure Temporary File Creation Vulnerability
Design Error 16250
No Yes
2006-01-16 12:00:00 2006-08-11 04:25:00
Discovered by Javier Fernandez-Sanguino Pena.

- 受影响的程序版本

Tux Paint Tux Paint 0.9.15 b
Tux Paint Tux Paint 0.9.14
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Ubuntu Ubuntu Linux 5.10 powerpc
+ Ubuntu Ubuntu Linux 5.10 i386
+ Ubuntu Ubuntu Linux 5.10 amd64

- 漏洞讨论

Tux Paint creates temporary files in an insecure manner.

Exploitation would most likely result in loss of data or a denial of service if critical files are overwritten in the attack. Other attacks may be possible as well.

- 漏洞利用

An exploit is not required.

- 解决方案

Please see the referenced advisories for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

Tux Paint Tux Paint 0.9.14

- 相关参考