CVE-2005-3335
CVSS7.5
发布时间 :2005-10-27 06:02:00
修订时间 :2011-03-07 21:26:20
NMCOP    

[原文]PHP file inclusion vulnerability in bug_sponsorship_list_view_inc.php in Mantis 1.0.0RC2 and 0.19.2 allows remote attackers to execute arbitrary PHP code and include arbitrary local files via the t_core_path parameter.


[CNNVD]Mantis bug_sponsorship_list_view_inc.php远程文件包含漏洞(CNNVD-200510-243)

        Mantis是用PHP脚本语言编写的基于web的漏洞跟踪系统。
        Mantis 1.0.0RC2, 0.19.2 中的bug_sponsorship_list_view_inc.php 文件存在php文件包含漏洞,允许攻击者通过 t_core_path 参数包含任意的本地文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mantis:mantis:0.19.2
cpe:/a:mantis:mantis:1.0.0_rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3335
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3335
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-243
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/secunia_research/2005-46/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2005-46/advisory/
http://secunia.com/advisories/16818
(VENDOR_ADVISORY)  SECUNIA  16818
http://bugs.mantisbt.org/changelog_page.php
(PATCH)  MISC  http://bugs.mantisbt.org/changelog_page.php
http://www.vupen.com/english/advisories/2005/2221
(UNKNOWN)  VUPEN  ADV-2005-2221
http://xforce.iss.net/xforce/xfdb/22886
(UNKNOWN)  XF  mantis-tcorepath-file-include(22886)
http://www.securityfocus.com/bid/15227
(UNKNOWN)  BID  15227
http://www.securityfocus.com/bid/15212
(UNKNOWN)  BID  15212
http://www.gentoo.org/security/en/glsa/glsa-200510-24.xml
(UNKNOWN)  GENTOO  GLSA-200510-24
http://www.debian.org/security/2005/dsa-905
(UNKNOWN)  DEBIAN  DSA-905
http://securitytracker.com/id?1015110
(UNKNOWN)  SECTRACK  1015110
http://securityreason.com/securityalert/121
(UNKNOWN)  SREASON  121
http://secunia.com/advisories/17654
(UNKNOWN)  SECUNIA  17654
http://secunia.com/advisories/17362
(UNKNOWN)  SECUNIA  17362
http://secunia.com/advisories/16506
(UNKNOWN)  SECUNIA  16506

- 漏洞信息

Mantis bug_sponsorship_list_view_inc.php远程文件包含漏洞
高危 资料不足
2005-10-27 00:00:00 2005-10-31 00:00:00
远程  
        Mantis是用PHP脚本语言编写的基于web的漏洞跟踪系统。
        Mantis 1.0.0RC2, 0.19.2 中的bug_sponsorship_list_view_inc.php 文件存在php文件包含漏洞,允许攻击者通过 t_core_path 参数包含任意的本地文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/mantisbt/mantis-0.19.3.tar.gz

- 漏洞信息 (F41751)

Debian Linux Security Advisory 905-1 (PacketStormID:F41751)
2005-11-22 00:00:00
Debian  security.debian.org
advisory,web
linux,debian
CVE-2005-3091,CVE-2005-3335,CVE-2005-3336,CVE-2005-3338
[点击下载]

Debian Security Advisory DSA 905-1 - Several security related problems have been discovered in Mantis, a web-based bug tracking system.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 905-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
November 22nd, 2005                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : mantis
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE IDs        : CVE-2005-3091 CVE-2005-3335 CVE-2005-3336 CVE-2005-3338
                 CVE-2005-3339
Debian Bugs    : 330682 335938

Several security related problems have been discovered in Mantis, a
web-based bug tracking system.  The Common Vulnerabilities and
Exposures project identifies the following problems:

CVE-2005-3091

    A cross-site scripting vulnerability allows attackers to inject
    arbitrary web script or HTML.

CVE-2005-3335

    A file inclusion vulnerability allows remote attackers to execute
    arbitrary PHP code and include arbitrary local files.

CVE-2005-3336

    An SQL injection vulnerability allows remote attackers to execute
    arbitrary SQL commands.

CVE-2005-3338

    Mantis can be tricked into displaying the otherwise hidden real
    mail address of its users.

The old stable distribution (woody) is not affected by these problems.

For the stable distribution (sarge) these problems have been fixed in
version 0.19.2-4.1.

For the unstable distribution (sid) these problems have been fixed in
version 0.19.3-0.1.

We recommend that you upgrade your mantis package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.1.dsc
      Size/MD5 checksum:      572 b7c83d901ff3cfa1c4cb54502e5519c7
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.1.diff.gz
      Size/MD5 checksum:    36447 e364d9ebb64a2071c3188baabb027dbd
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2.orig.tar.gz
      Size/MD5 checksum:  1298615 042c42c6de3bc536181391c1e9b25db3

  Architecture independent components:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.1_all.deb
      Size/MD5 checksum:   895006 4131ad481a77292789af31e00a7960e6


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDgrHkW5ql+IAeqTIRArQQAKCvWlF6/DgFKfQBMqBw5+obzvKVPACgkRJS
jEbvyhlw3wF5vu3UinSyDIk=
=CVPy
-----END PGP SIGNATURE-----

    

- 漏洞信息

20319
Mantis bug_sponsorship_list_view_inc.php t_core_path Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-10-11 2005-09-19
2005-10-26 Unknow

- 解决方案

Upgrade to version 0.19.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站