发布时间 :2005-10-27 06:02:00
修订时间 :2008-09-05 16:54:05

[原文]Cross-site scripting (XSS) vulnerability in index.php in Flyspray 0.9.7 through 0.9.8 (devel) allows remote attackers to inject arbitrary web script or HTML via the (1) PHPSESSID, (2) task, (3) string, (4) type, (5) serv, (6) due, (7) dev, and (8) sort2 parameters.


        Flyspray 是一个基于web的bug追踪系统软件。
        Flyspray 0.9.7到0.9.8(devel)的index.php存在跨站脚本攻击(XSS) 漏洞。远程攻击者可以借助(1) PHPSESSID, (2) task, (3) string, (4) type, (5) serv, (6) due, (7) dev和(8) sort2参数,注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  flyspray-index-xss(22889)
(UNKNOWN)  BID  15209

- 漏洞信息

中危 跨站脚本
2005-10-27 00:00:00 2006-01-19 00:00:00
        Flyspray 是一个基于web的bug追踪系统软件。
        Flyspray 0.9.7到0.9.8(devel)的index.php存在跨站脚本攻击(XSS) 漏洞。远程攻击者可以借助(1) PHPSESSID, (2) task, (3) string, (4) type, (5) serv, (6) due, (7) dev和(8) sort2参数,注入任意web脚本或HTML。

- 公告与补丁


- 漏洞信息

Flyspray index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Flyspray contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'PHPSESSID', 'tasks', 'string', 'type', 'serv', 'due', 'dev', and 'sort2' variables upon submission to the 'index.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-10-26 2005-10-20
2005-10-26 Unknow

- 解决方案

Upgrade to version 0.9.8 (2005-11-01) or higher, as it has been reported to fix this vulnerability. Note that this flaw was fixed in the 2005-11-01 release without a change in version number. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Flyspray Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 15209
Yes No
2005-10-26 12:00:00 2006-02-07 08:54:00
lostmon is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

Flyspray Flyspray 0.9.8 development
Flyspray Flyspray 0.9.8
Flyspray Flyspray 0.9.7
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

Flyspray is prone to multiple cross-site scripting vulnerabilities. These issues are due to a lack of proper sanitization of user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required.

Example URI have been provided:

- 解决方案

Debian Linux has released security advisory DSA 953-1 to address this issue. Please see the referenced advisory for further information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考