发布时间 :2005-10-27 06:02:00
修订时间 :2011-03-07 21:26:16

[原文]Buffer overflow in the _chm_decompress_block function in CHM lib (chmlib) before 0.37, as used in products such as KchmViewer, allows attackers execute arbitrary code, a different vulnerability than CVE-2005-2930.

[CNNVD]Jed Wing CHM Lib 堆栈缓冲区溢出漏洞(CNNVD-200510-233)

        CHM 是一款处理 Microsoft ITSS/CHM 格式文件的库。
        用于KchmViewer等产品的CHM lib (chmlib)0.37之前版本的 _chm_decompress_block函数存在缓冲区溢出,可以使远程攻击者执行任意代吗。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  15211
(UNKNOWN)  XF  chmlib-chmdecompressblock-bo(22885)
(UNKNOWN)  VUPEN  ADV-2005-2207
(UNKNOWN)  FULLDISC  20051026 chmlib exploitable buffer overflow

- 漏洞信息

Jed Wing CHM Lib 堆栈缓冲区溢出漏洞
中危 缓冲区溢出
2005-10-27 00:00:00 2006-06-13 00:00:00
        CHM 是一款处理 Microsoft ITSS/CHM 格式文件的库。
        用于KchmViewer等产品的CHM lib (chmlib)0.37之前版本的 _chm_decompress_block函数存在缓冲区溢出,可以使远程攻击者执行任意代吗。

- 公告与补丁


- 漏洞信息 (F41388)

Debian Linux Security Advisory 886-1 (PacketStormID:F41388)
2005-11-08 00:00:00

Debian Security Advisory DSA 886-1 - Several vulnerabilities have been discovered in chmlib, a library for dealing with CHM format files.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 886-1                                        Martin Schulze
November 7th, 2005            
- --------------------------------------------------------------------------

Package        : chmlib
Vulnerability  : several
Problem type   : local (remote)
Debian-specific: no
CVE IDs        : CVE-2005-2659 CVE-2005-2930 CVE-2005-3318
BugTraq ID     : 15211

Several vulnerabilities have been discovered in chmlib, a library for
dealing with CHM format files.  The Common Vulnerabilities and
Exposures project identifies the following problems:


    Palasik Sandor discoverd a buffer overflow in the LZX
    decompression method.


    A buffer overflow has been discovered that could lead to the
    execution of arbitrary code.


    Sven Tantau discoverd a buffer overflow that could lead to the
    execution of arbitrary code.

The old stable distribution (woody) does not contain chmlib packages.

For the stable distribution (sarge) these problems have been fixed in
version 0.35-6sarge1.

For the unstable distribution (sid) these problems have been fixed in
version 0.37-2.

We recommend that you upgrade your chmlib packages.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:
      Size/MD5 checksum:      604 022d55ea43ef4a54648b0823163c4a07
      Size/MD5 checksum:    15698 55eeab9a32a66c5e123ab51f3d7427df
      Size/MD5 checksum:   368428 8fa0e692b2606a03fb51589f66a82eec

  Alpha architecture:
      Size/MD5 checksum:    25688 2471920dc5214b95a44e50e2a8800ada
      Size/MD5 checksum:    18576 0b1d802a79cea68c00d36cd9cb7a36cd
      Size/MD5 checksum:    25544 23306cc3f7b0772f744707c86fa9258a

  AMD64 architecture:
      Size/MD5 checksum:    23748 e5a72c3311e7b00d6295a75f7bb37560
      Size/MD5 checksum:    16928 8a2d68579e364a284c03dcc4b9a01e37
      Size/MD5 checksum:    22564 50d2a8d694d1bf7251d18b4f7b02ede7

  ARM architecture:
      Size/MD5 checksum:    25242 ec14b38be010c3f1fee93dd618124c5e
      Size/MD5 checksum:    15962 5e1ec37635078cc29b9f2a4f91f9b20e
      Size/MD5 checksum:    24000 bc84ed2d77918f6eb4378f35f43cd4e5

  Intel IA-32 architecture:
      Size/MD5 checksum:    24872 fbea0ba2924295a9f553c346eeb164af
      Size/MD5 checksum:    16094 de94d72e5414d1b218fd32f11cd7351b
      Size/MD5 checksum:    22872 3e37bda96c284423f467aecb88e8dc98

  Intel IA-64 architecture:
      Size/MD5 checksum:    28504 ef19dde34158fa817781c685d2499cbb
      Size/MD5 checksum:    19348 e15dc8288ba0a0bee7a9490c4fe653de
      Size/MD5 checksum:    27268 497388fcd7e08a7558dde96082b2707a

  HP Precision architecture:
      Size/MD5 checksum:    27748 1be03e42641d4a3a409bf5604e1b15a8
      Size/MD5 checksum:    18060 290679f0522440bd4ab925fb3f883b60
      Size/MD5 checksum:    24192 7e4c8b5b62bb7ab2eb14f01e54b64453

  Motorola 680x0 architecture:
      Size/MD5 checksum:    23124 e845c33b36a51d713fd4cf5ba24aa136
      Size/MD5 checksum:    16256 25a7901e4b91497528bdf582b43b5df3
      Size/MD5 checksum:    21626 aa4166c4ee0660cbf5ecefff086e871b

  Big endian MIPS architecture:
      Size/MD5 checksum:    26552 456bd641bda1da859c9769c5dbac0212
      Size/MD5 checksum:    23108 5f289432c7bcfb2bf5945b688aa3e80a
      Size/MD5 checksum:    25098 589bb8b01be1943c4813afb477b1a83c

  Little endian MIPS architecture:
      Size/MD5 checksum:    26582 36348c9aa4b47d9426481a2faf90e98a
      Size/MD5 checksum:    23128 c970a6faf21ba157d72c1dd8720fe307
      Size/MD5 checksum:    25082 4bb261ab9c4b19623a0e53e0063f920f

  PowerPC architecture:
      Size/MD5 checksum:    27380 7e7d08b907286bf4b326a97ed0b9ad72
      Size/MD5 checksum:    22032 a24a33a3eba0b35608f23159fab58a4d
      Size/MD5 checksum:    23558 6a0564ea6c10034569bf0b428c372dd9

  IBM S/390 architecture:
      Size/MD5 checksum:    26606 d2b7c824f1118f3088daacd66c9e6e61
      Size/MD5 checksum:    17486 42591c148ddfb9df1a3c1d9006e609e5
      Size/MD5 checksum:    23454 e4a6426fe3831ebb9e2afc47565fa191

  Sun Sparc architecture:
      Size/MD5 checksum:    24332 b41c04b1d6df50931ddfe8eafa61d19f
      Size/MD5 checksum:    16110 17aba1dae25700043a23aa9863a190f0
      Size/MD5 checksum:    22330 5e0e711c063af5b5c982224d1eeef5e5

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.4.2 (GNU/Linux)



- 漏洞信息

chmlib _chm_decompress_block() Function CHM File Processing Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in chmlib. The library function "_chm_decompress_block()" fails to perform proper bounds checking, resulting in a stack-based buffer overflow. With a specially crafted CHM file, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-10-26 2005-10-24
Unknow Unknow

- 解决方案

Upgrade to version 0.37 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Jed Wing CHM Lib Stack Buffer Overflow Vulnerability
Boundary Condition Error 15211
Yes No
2005-10-26 12:00:00 2005-10-26 12:00:00
Sven Tantau discovered this vulnerability.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Personal 10.0 OSS
Jed Wing CHM lib 0.36
Jed Wing CHM lib 0.35
Jed Wing CHM lib 0.33
Jed Wing CHM lib 0.32
Jed Wing CHM lib 0.31
Jed Wing CHM lib 0.3
Jed Wing CHM lib 0.2
Jed Wing CHM lib 0.1
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Jed Wing CHM lib 0.37

- 不受影响的程序版本

Jed Wing CHM lib 0.37

- 漏洞讨论

CHM lib is susceptible to a buffer overflow vulnerability. This issue is due to a failure of the library to properly bounds check input data prior to copying it into an insufficiently sized memory buffer.

This issue allows attackers to execute arbitrary machine code in the context of the application that utilizes the CHM lib library.

This issue is present in versions 0.36 and prior of the library.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

The vendor has released version 0.37 of CHM lib to address this issue:

SUSE has released advisory SUSE-SR:2005:025 to address this, and other issues in various packages, in various SUSE products. Please see the referenced advisory for further information.

Debian has released advisory DSA 886-1 to address this issue. Please see the referenced advisory for more information.

Gentoo has released advisory GLSA 200511-23 to address this issue. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to update their computers:

All chmlib users:

emerge --sync
emerge --ask --oneshot --verbose ">=app-doc/chmlib-0.37.4"

All KchmViewer users:

emerge --sync
emerge --ask --oneshot --verbose ">=app-doc/kchmviewer-1.1"

Jed Wing CHM lib 0.1

Jed Wing CHM lib 0.2

Jed Wing CHM lib 0.3

Jed Wing CHM lib 0.31

Jed Wing CHM lib 0.32

Jed Wing CHM lib 0.33

Jed Wing CHM lib 0.35

Jed Wing CHM lib 0.36

- 相关参考