CVE-2005-3307
CVSS5.0
发布时间 :2005-10-25 21:02:00
修订时间 :2016-10-17 23:34:23
NMCO    

[原文]Directory traversal vulnerability in index.php for FlatNuke 2.5.6 allows remote attackers to read arbitrary files via ".." sequences in the (1) user parameter in a profile operation or (2) quale parameter in a newtopic operation.


[CNNVD]FlatNuke Index.PHP 多个远程文件包含漏洞(CNNVD-200510-215)

        FlatNuke 是一个PHP 开发的内容管理系统,无须数据库支持,使用的是文本文件来保存内容。
        FlatNuke 2.5.6的index.php中存在目录遍历漏洞,远程攻击者可以通过(1)profile操作中的user参数或(2)newtopic操作中的quale参数中的".."(参数中包含'..')序列,读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3307
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3307
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-215
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=113018940229407&w=2
(UNKNOWN)  BUGTRAQ  20051022 File Including In FLAT NUKE
http://www.securityfocus.com/bid/15172
(UNKNOWN)  BID  15172
http://www.vupen.com/english/advisories/2005/2178
(UNKNOWN)  VUPEN  ADV-2005-2178

- 漏洞信息

FlatNuke Index.PHP 多个远程文件包含漏洞
中危 路径遍历
2005-10-25 00:00:00 2005-10-31 00:00:00
远程  
        FlatNuke 是一个PHP 开发的内容管理系统,无须数据库支持,使用的是文本文件来保存内容。
        FlatNuke 2.5.6的index.php中存在目录遍历漏洞,远程攻击者可以通过(1)profile操作中的user参数或(2)newtopic操作中的quale参数中的".."(参数中包含'..')序列,读取任意文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        FlatNuke FlatNuke 2.5.1
        FlatNuke flatnuke-2.5.7-20051024.tar.gz
        http://flatnuke.sourceforge.net/nightly/flatnuke-2.5.7-20051024.tar.gz
        FlatNuke FlatNuke 2.5.2
        FlatNuke flatnuke-2.5.7-20051024.tar.gz
        http://flatnuke.sourceforge.net/nightly/flatnuke-2.5.7-20051024.tar.gz
        FlatNuke FlatNuke 2.5.3
        FlatNuke flatnuke-2.5.7-20051024.tar.gz
        http://flatnuke.sourceforge.net/nightly/flatnuke-2.5.7-20051024.tar.gz
        FlatNuke FlatNuke 2.5.4
        FlatNuke flatnuke-2.5.7-20051024.tar.gz
        http://flatnuke.sourceforge.net/nightly/flatnuke-2.5.7-20051024.tar.gz
        FlatNuke FlatNuke 2.5.5
        FlatNuke flatnuke-2.5.7-20051024.tar.gz
        http://flatnuke.sourceforge.net/nightly/flatnuke-2.5.7-20051024.tar.gz
        
        FlatNuke FlatNuke 2.5.6
        FlatNuke flatnuke-2.5.7-20051024.tar.gz
        http://flatnuke.sourceforge.net/nightly/flatnuke-2.5.7-20051024.tar.gz

- 漏洞信息

20245
FlatNuke index.php Traversal Arbitrary File Inclusion
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality

- 漏洞描述

FlatNuke contains a flaw that may allow a remote attacker to include arbitrary files. The issue is due to the 'index.php' script not properly sanitizing user input, specifically traversal style attacks supplied via the 'user' and 'quale' variables, which may allow a remote attacker to disclose the content of arbitrary files resulting in a loss of confidentiality.

- 时间线

2005-10-22 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站