CVE-2005-3302
CVSS7.5
发布时间 :2005-10-24 06:02:00
修订时间 :2008-09-05 16:54:00
NMCOS    

[原文]Eval injection vulnerability in bvh_import.py in Blender 2.36 allows attackers to execute arbitrary Python code via a hierarchy element in a .bvh file, which is supplied to an eval function call.


[CNNVD]Blender BVF 文件导入Python代码执行漏洞(CNNVD-200510-192)

        Blender是一套三维绘图及绚染软件。
        Blender 2.36中的bvh_import.py存在Eval注入漏洞。攻击者可以借助供eval函数调用的.bvh文件中的层次要素,执行任意Python代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3302
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3302
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-192
(官方数据源) CNNVD

- 其它链接及资源

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=330895
(VENDOR_ADVISORY)  MISC  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=330895
http://www.securityfocus.com/bid/17663
(UNKNOWN)  BID  17663
http://www.debian.org/security/2006/dsa-1039
(UNKNOWN)  DEBIAN  DSA-1039
http://secunia.com/advisories/19754
(UNKNOWN)  SECUNIA  19754

- 漏洞信息

Blender BVF 文件导入Python代码执行漏洞
高危 边界条件错误
2005-10-24 00:00:00 2005-10-25 00:00:00
远程  
        Blender是一套三维绘图及绚染软件。
        Blender 2.36中的bvh_import.py存在Eval注入漏洞。攻击者可以借助供eval函数调用的.bvh文件中的层次要素,执行任意Python代码。

- 公告与补丁

        暂无数据

- 漏洞信息

21583
Blender bvh_import.py Eval Injection Arbitrary Command Execution
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-09-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Blender BVF File Import Python Code Execution Vulnerability
Boundary Condition Error 17663
Yes No
2006-04-24 12:00:00 2006-12-14 04:38:00
Joxean Koret <joxeankoret@yahoo.es> discovered this issue.

- 受影响的程序版本

Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Blender Blender 2.36

- 漏洞讨论

Blender is susceptible to a Python code-execution vulnerability. This issue is due to the application's failure to properly sanitize user-supplied input before using it in a Python 'eval' statement.

This issue allows attackers to execute arbitrary Python code in the context of the user running the affected application.

- 漏洞利用

BVH files are text-based, allowing attackers to use standard utilities to exploit this vulnerability.

The following example BVH files are sufficient to demonstrate this issue:

http://bugs.debian.org/cgi-bin/bugreport.cgi/exploit.bvh?bug=330895;msg=5;att=1
http://bugs.debian.org/cgi-bin/bugreport.cgi/poc1.bvh?bug=330895;msg=5;att=3
http://bugs.debian.org/cgi-bin/bugreport.cgi/poc2.bvh?bug=330895;msg=5;att=4

- 解决方案

The vendor has committed fixes to their CVS repository to address this issue.

Please see the referenced advisories for further information on obtaining and applying fixes.


Blender Blender 2.36

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站