CVE-2005-3165
CVSS4.3
发布时间 :2005-10-06 06:02:00
修订时间 :2008-09-05 16:53:38
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in MediaWiki before 1.4.9 allow remote attackers to inject arbitrary web script or HTML via (1) <math> tags or (2) Extension or <nowiki> sections that "bypass HTML style attribute restrictions" that are intended to protect against XSS vulnerabilities in Internet Explorer clients.


[CNNVD]MediaWiki 跨站脚本漏洞(CNNVD-200510-045)

        MediaWiki是一套最早为维基百科量身打造的自由免费的wiki套件。
        MediaWiki 1.4.9之前版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助用于防止Internet Explorer 客户端XSS漏洞的,可以"绕过 HTML样式属性限制"的(1)标签或(2)Extension或部分,注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.4.6MediaWiki 1.4.6
cpe:/a:mediawiki:mediawiki:1.4_beta5
cpe:/a:mediawiki:mediawiki:1.4_beta6
cpe:/a:mediawiki:mediawiki:1.4.1MediaWiki 1.4.1
cpe:/a:mediawiki:mediawiki:1.4.2MediaWiki 1.4.2
cpe:/a:mediawiki:mediawiki:1.4_beta4
cpe:/a:mediawiki:mediawiki:1.4.8MediaWiki 1.4.8
cpe:/a:mediawiki:mediawiki:1.4.7MediaWiki 1.4.7
cpe:/a:mediawiki:mediawiki:1.4_beta3
cpe:/a:mediawiki:mediawiki:1.4.3MediaWiki 1.4.3
cpe:/a:mediawiki:mediawiki:1.4_beta2
cpe:/a:mediawiki:mediawiki:1.4_beta1
cpe:/a:mediawiki:mediawiki:1.4.5MediaWiki 1.4.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3165
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3165
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-045
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=352777
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=352777
http://secunia.com/advisories/16932
(VENDOR_ADVISORY)  SECUNIA  16932
http://lwn.net/Articles/153906/
(VENDOR_ADVISORY)  SUSE  SUSE-SR:2005:021

- 漏洞信息

MediaWiki 跨站脚本漏洞
中危 跨站脚本
2005-10-06 00:00:00 2006-04-07 00:00:00
远程  
        MediaWiki是一套最早为维基百科量身打造的自由免费的wiki套件。
        MediaWiki 1.4.9之前版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助用于防止Internet Explorer 客户端XSS漏洞的,可以"绕过 HTML样式属性限制"的(1)标签或(2)Extension或部分,注入任意web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

19732
MediaWiki math Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Private Vendor Verified

- 漏洞描述

MediaWiki contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the '<math>' tags. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-08-29 Unknow
Unknow 2005-08-29

- 解决方案

Upgrade to version 1.4.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站