CVE-2005-3163
CVSS5.0
发布时间 :2005-10-06 06:02:00
修订时间 :2008-09-05 16:53:37
NMCO    

[原文]Unspecified vulnerability in Polipo 0.9.8 and earlier allows attackers to read files outside of the web root.


[CNNVD]Polipo Web根目录限制绕过漏洞(CNNVD-200510-047)

        Polipo是一个小型的代理服务器软件, 被设计为一个人或者几个人使用的代理服务器软件
        Polipo 0.9.8及之前版本存在未明漏洞。远程攻击者可以读取web根目录以外的文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:polipo:polipo:0.9.5
cpe:/a:polipo:polipo:0.9.3
cpe:/a:polipo:polipo:0.9.8
cpe:/a:polipo:polipo:0.9.4
cpe:/a:polipo:polipo:0.9.1
cpe:/a:polipo:polipo:0.9.7
cpe:/a:polipo:polipo:0.9.6
cpe:/a:polipo:polipo:0.9.2
cpe:/a:polipo:polipo:0.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3163
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3163
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-047
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14970
(PATCH)  BID  14970
http://www.pps.jussieu.fr/~jch/software/polipo/CHANGES.text
(UNKNOWN)  CONFIRM  http://www.pps.jussieu.fr/~jch/software/polipo/CHANGES.text

- 漏洞信息

Polipo Web根目录限制绕过漏洞
中危 设计错误
2005-10-06 00:00:00 2005-10-20 00:00:00
远程  
        Polipo是一个小型的代理服务器软件, 被设计为一个人或者几个人使用的代理服务器软件
        Polipo 0.9.8及之前版本存在未明漏洞。远程攻击者可以读取web根目录以外的文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Polipo Polipo 0.9
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.1
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.2
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.3
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.4
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.5
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.6
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.7
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz
        Polipo Polipo 0.9.8
        Polipo polipo-0.9.9.tar.gz
        http://www.pps.jussieu.fr/~jch/software/files/polipo/polipo-0.9.9.tar.gz

- 漏洞信息

19693
Polipo Unspecified Traversal Arbitrary File Access
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality
Exploit Unknown Vendor Verified

- 漏洞描述

Polipo contains a flaw that allows a remote attacker to access arbitrary files outside of the web path. No further details have been provided.

- 时间线

2005-09-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站