CVE-2005-3142
CVSS10.0
发布时间 :2005-10-05 17:02:00
修订时间 :2016-10-17 23:33:09
NMCO    

[原文]Heap-based buffer overflow in Kaspersky Antivirus (KAV) 5.0 and Kaspersky Personal Security Suite 1.1 allows remote attackers to execute arbitrary code via a CAB file with large records after the header.


[CNNVD]Kaspersky Anti-Virus Library CAB Record 远程堆溢出漏洞(CNNVD-200510-024)

        Kaspersky Antivirus 是卡巴斯基公司出品的首屈一指的杀毒软件。
        Kaspersky Antivirus (KAV) 5.0和Kaspersky Personal Security Suite 1.1存在堆缓冲区溢出漏洞。远程攻击者可以借助header后面带有大记录的CAB文件,执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:kaspersky_lab:kaspersky_anti-virus_personal_pro:5.0
cpe:/a:kaspersky_lab:kaspersky_personal_security_suite:1.1
cpe:/a:kaspersky_lab:kaspersky_anti-virus:5.0::windows_file_servers
cpe:/a:kaspersky_lab:kaspersky_anti-virus:5.0::windows_workstations
cpe:/a:kaspersky_lab:kaspersky_anti-virus_personal:5.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3142
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3142
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-024
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/fulldisclosure/2005-10/0018.html
(UNKNOWN)  FULLDISC  20051003 Kaspersky Antivirus Library Remote Heap Overflow
http://marc.info/?l=bugtraq&m=112837961522571&w=2
(UNKNOWN)  BUGTRAQ  20051003 Kaspersky Antivirus Remote Heap Overflow
http://securityreason.com/securityalert/44
(UNKNOWN)  SREASON  44
http://securitytracker.com/id?1014998
(UNKNOWN)  SECTRACK  1014998
http://www.kaspersky.com/news?id=171512144
(VENDOR_ADVISORY)  CONFIRM  http://www.kaspersky.com/news?id=171512144
http://www.rem0te.com/public/images/kaspersky.pdf
(VENDOR_ADVISORY)  MISC  http://www.rem0te.com/public/images/kaspersky.pdf
http://www.securityfocus.com/bid/14998
(UNKNOWN)  BID  14998
http://www.vupen.com/english/advisories/2005/1934
(UNKNOWN)  VUPEN  ADV-2005-1934
http://xforce.iss.net/xforce/xfdb/22497
(UNKNOWN)  XF  kaspersky-cab-heap-overflow(22497)

- 漏洞信息

Kaspersky Anti-Virus Library CAB Record 远程堆溢出漏洞
危急 缓冲区溢出
2005-10-05 00:00:00 2006-03-08 00:00:00
远程  
        Kaspersky Antivirus 是卡巴斯基公司出品的首屈一指的杀毒软件。
        Kaspersky Antivirus (KAV) 5.0和Kaspersky Personal Security Suite 1.1存在堆缓冲区溢出漏洞。远程攻击者可以借助header后面带有大记录的CAB文件,执行任意代码。

- 公告与补丁

        暂无数据

- 漏洞信息

19850
Kaspersky Anti-Virus cab.ppl CAB Archive Handling Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in Kapersky Anti-Virus. The 'cab.ppl' engine fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted CAB archive, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-10-03 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Kaspersky Lab has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站