CVE-2005-3115
CVSS2.1
发布时间 :2005-09-30 14:05:00
修订时间 :2008-09-05 16:53:30
NMCOPS    

[原文]mpeg-tools before 1.5b-r2 creates multiple temporary files insecurely, which allows local users to overwrite arbitrary files via (1) ts.stat, (2) ts.mpg, (3) foobar, (4) blockbar, or (5) foobar[NNN].


[CNNVD]Berkeley MPEG工具不安全临时文件创建漏洞(CNNVD-200509-295)

        mpeg-tools是一款MPEG文件工具,它有两个作用:一是把dat格式的文件转换成MPEG格式的文件,另一个是可以用来分割MPEG文件。
        mpeg-tools 1.5b-r2之前的版本创建的多个临时文件安全性差,本地用户可通过(1) ts.stat, (2) ts.mpg, (3) foobar, (4) blockbar, 或(5) foobar[NNN]覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3115
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3115
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-295
(官方数据源) CNNVD

- 其它链接及资源

https://bugs.gentoo.org/show_bug.cgi?id=107344
(UNKNOWN)  CONFIRM  https://bugs.gentoo.org/show_bug.cgi?id=107344
http://www.securityfocus.com/bid/15002
(UNKNOWN)  BID  15002
http://www.gentoo.org/security/en/glsa/glsa-200510-02.xml
(UNKNOWN)  GENTOO  GLSA-200510-02
http://secunia.com/advisories/17051
(UNKNOWN)  SECUNIA  17051
http://secunia.com/advisories/17008
(UNKNOWN)  SECUNIA  17008

- 漏洞信息

Berkeley MPEG工具不安全临时文件创建漏洞
低危 设计错误
2005-09-30 00:00:00 2005-10-20 00:00:00
本地  
        mpeg-tools是一款MPEG文件工具,它有两个作用:一是把dat格式的文件转换成MPEG格式的文件,另一个是可以用来分割MPEG文件。
        mpeg-tools 1.5b-r2之前的版本创建的多个临时文件安全性差,本地用户可通过(1) ts.stat, (2) ts.mpg, (3) foobar, (4) blockbar, 或(5) foobar[NNN]覆盖任意文件。

- 公告与补丁

        暂无数据

- 漏洞信息 (F40437)

Gentoo Linux Security Advisory 200510-2 (PacketStormID:F40437)
2005-10-06 00:00:00
Gentoo  security.gentoo.org
advisory
linux,gentoo
CVE-2005-3115
[点击下载]

Gentoo Linux Security Advisory GLSA 200510-02 - Mike Frysinger of the Gentoo Security Team discovered that mpeg_encode and the conversion utilities were creating temporary files with predictable or fixed filenames. The 'test' make target of the MPEG Tools also relied on several temporary files created insecurely. Versions less than 1.5b-r2 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200510-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Berkeley MPEG Tools: Multiple insecure temporary files
      Date: October 03, 2005
      Bugs: #107344
        ID: 200510-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The Berkeley MPEG Tools use temporary files in various insecure ways,
potentially allowing a local user to overwrite arbitrary files.

Background
==========

The Berkeley MPEG Tools are a collection of utilities for manipulating
MPEG video technology, including an encoder (mpeg_encode) and various
conversion utilities.

Affected packages
=================

    -------------------------------------------------------------------
     Package                 /  Vulnerable  /               Unaffected
    -------------------------------------------------------------------
  1  media-video/mpeg-tools      < 1.5b-r2                  >= 1.5b-r2

Description
===========

Mike Frysinger of the Gentoo Security Team discovered that mpeg_encode
and the conversion utilities were creating temporary files with
predictable or fixed filenames. The 'test' make target of the MPEG
Tools also relied on several temporary files created insecurely.

Impact
======

A local attacker could create symbolic links in the temporary files
directory, pointing to a valid file somewhere on the filesystem. When
the utilities are executed (or 'make test' is run), this would result
in the file being overwritten with the rights of the user running the
command.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Berkeley MPEG Tools users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-video/mpeg-tools-1.5b-r2"

References
==========

  [ 1 ] CAN-2005-3115
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-3115

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200510-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

    

- 漏洞信息

19843
Berkeley MPEG Tools mpeg_encode/parallel.c Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-09-26 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Berkeley MPEG Tools Insecure Temporary File Creation Vulnerabilities
Design Error 15002
No Yes
2005-10-03 12:00:00 2009-07-12 05:06:00
Discovery is credited to Mike Frysinger of the Gentoo Security Team.

- 受影响的程序版本

Gentoo Linux
Berkeley MPEG Tools Berkeley MPEG Tools 1.5 b

- 漏洞讨论

Berkeley MPEG Tools creates temporary files in an insecure manner.

Successful exploitation may result in sensitive data or configuration files being overwritten. This may result in a denial of service due to data corruption; other attacks may also be possible.

Berkeley MPEG Tools 1.5b is known to be vulnerable at the moment. Other versions may be affected as well.

- 漏洞利用

No exploit is required.

- 解决方案

Gentoo has released advisory GLSA 200510-02 to address these issues. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to update their computers:

emerge --sync
emerge --ask --oneshot --verbose ">=media-video/mpeg-tools-1.5b-r2"

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站