CVE-2005-3091
CVSS4.3
发布时间 :2005-09-28 18:03:00
修订时间 :2008-09-05 16:53:26
NMCPS    

[原文]Cross-site scripting (XSS) vulnerability in Mantis before 1.0.0rc1 allows remote attackers to inject arbitrary web script or HTML via unknown attack vectors, as identified by bug#0005751 "thraxisp".


[CNNVD]Mantis 未知跨站脚本漏洞(CNNVD-200509-284)

        Mantis是用PHP脚本语言编写的基于web的漏洞跟踪系统。
        Mantis 1.0.0rc1 以前的版本存在跨站脚本漏洞,这允许远程攻击者通过未知的载体(例如标记为 bug#0005751 "thraxisp")实现注入任意的WEB代码或HTML.

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mantis:mantis:0.15.2
cpe:/a:mantis:mantis:1.0.0a1
cpe:/a:mantis:mantis:0.14.4
cpe:/a:mantis:mantis:0.14.0
cpe:/a:mantis:mantis:0.10.2
cpe:/a:mantis:mantis:0.18.0a3
cpe:/a:mantis:mantis:0.14.2
cpe:/a:mantis:mantis:0.11.0
cpe:/a:mantis:mantis:0.18.0a2
cpe:/a:mantis:mantis:0.9.1
cpe:/a:mantis:mantis:0.17.3
cpe:/a:mantis:mantis:0.15.7
cpe:/a:mantis:mantis:0.15.6
cpe:/a:mantis:mantis:0.16.1
cpe:/a:mantis:mantis:0.14.6
cpe:/a:mantis:mantis:0.19.0a2
cpe:/a:mantis:mantis:0.15.12
cpe:/a:mantis:mantis:0.11.1
cpe:/a:mantis:mantis:0.19.0
cpe:/a:mantis:mantis:0.18.0a1
cpe:/a:mantis:mantis:0.15.4
cpe:/a:mantis:mantis:0.17.2
cpe:/a:mantis:mantis:0.17.4
cpe:/a:mantis:mantis:1.0.0a2
cpe:/a:mantis:mantis:0.19.2
cpe:/a:mantis:mantis:0.13.0
cpe:/a:mantis:mantis:0.19.1
cpe:/a:mantis:mantis:0.19.0_rc1
cpe:/a:mantis:mantis:0.19.0a1
cpe:/a:mantis:mantis:0.10.0
cpe:/a:mantis:mantis:0.9.0
cpe:/a:mantis:mantis:0.14.7
cpe:/a:mantis:mantis:0.13.1
cpe:/a:mantis:mantis:0.18.0_rc1
cpe:/a:mantis:mantis:0.18.1
cpe:/a:mantis:mantis:0.14.1
cpe:/a:mantis:mantis:0.18.3
cpe:/a:mantis:mantis:0.15.3
cpe:/a:mantis:mantis:0.17.4a
cpe:/a:mantis:mantis:0.15.8
cpe:/a:mantis:mantis:0.15.9
cpe:/a:mantis:mantis:0.17.0
cpe:/a:mantis:mantis:0.17.1
cpe:/a:mantis:mantis:0.14.5
cpe:/a:mantis:mantis:0.10.1
cpe:/a:mantis:mantis:0.15.5
cpe:/a:mantis:mantis:0.18.0a4
cpe:/a:mantis:mantis:0.16.0
cpe:/a:mantis:mantis:0.18.2
cpe:/a:mantis:mantis:0.14.3
cpe:/a:mantis:mantis:0.15.11
cpe:/a:mantis:mantis:0.15.1
cpe:/a:mantis:mantis:0.15.10
cpe:/a:mantis:mantis:0.14.8
cpe:/a:mantis:mantis:1.0.0a3
cpe:/a:mantis:mantis:0.18.0
cpe:/a:mantis:mantis:0.15.0
cpe:/a:mantis:mantis:0.17.5
cpe:/a:mantis:mantis:0.12.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3091
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3091
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-284
(官方数据源) CNNVD

- 其它链接及资源

http://www.mantisbt.org/changelog.php
(UNKNOWN)  CONFIRM  http://www.mantisbt.org/changelog.php
http://www.securityfocus.com/bid/15227
(UNKNOWN)  BID  15227
http://www.debian.org/security/2005/dsa-905
(UNKNOWN)  DEBIAN  DSA-905
http://secunia.com/advisories/17654
(UNKNOWN)  SECUNIA  17654
http://secunia.com/advisories/16506
(UNKNOWN)  SECUNIA  16506

- 漏洞信息

Mantis 未知跨站脚本漏洞
中危 跨站脚本
2005-09-28 00:00:00 2005-10-20 00:00:00
远程  
        Mantis是用PHP脚本语言编写的基于web的漏洞跟踪系统。
        Mantis 1.0.0rc1 以前的版本存在跨站脚本漏洞,这允许远程攻击者通过未知的载体(例如标记为 bug#0005751 "thraxisp")实现注入任意的WEB代码或HTML.

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/mantisbt/mantis-0.19.3.tar.gz

- 漏洞信息 (F41751)

Debian Linux Security Advisory 905-1 (PacketStormID:F41751)
2005-11-22 00:00:00
Debian  security.debian.org
advisory,web
linux,debian
CVE-2005-3091,CVE-2005-3335,CVE-2005-3336,CVE-2005-3338
[点击下载]

Debian Security Advisory DSA 905-1 - Several security related problems have been discovered in Mantis, a web-based bug tracking system.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 905-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
November 22nd, 2005                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : mantis
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE IDs        : CVE-2005-3091 CVE-2005-3335 CVE-2005-3336 CVE-2005-3338
                 CVE-2005-3339
Debian Bugs    : 330682 335938

Several security related problems have been discovered in Mantis, a
web-based bug tracking system.  The Common Vulnerabilities and
Exposures project identifies the following problems:

CVE-2005-3091

    A cross-site scripting vulnerability allows attackers to inject
    arbitrary web script or HTML.

CVE-2005-3335

    A file inclusion vulnerability allows remote attackers to execute
    arbitrary PHP code and include arbitrary local files.

CVE-2005-3336

    An SQL injection vulnerability allows remote attackers to execute
    arbitrary SQL commands.

CVE-2005-3338

    Mantis can be tricked into displaying the otherwise hidden real
    mail address of its users.

The old stable distribution (woody) is not affected by these problems.

For the stable distribution (sarge) these problems have been fixed in
version 0.19.2-4.1.

For the unstable distribution (sid) these problems have been fixed in
version 0.19.3-0.1.

We recommend that you upgrade your mantis package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.1.dsc
      Size/MD5 checksum:      572 b7c83d901ff3cfa1c4cb54502e5519c7
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.1.diff.gz
      Size/MD5 checksum:    36447 e364d9ebb64a2071c3188baabb027dbd
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2.orig.tar.gz
      Size/MD5 checksum:  1298615 042c42c6de3bc536181391c1e9b25db3

  Architecture independent components:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.1_all.deb
      Size/MD5 checksum:   895006 4131ad481a77292789af31e00a7960e6


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDgrHkW5ql+IAeqTIRArQQAKCvWlF6/DgFKfQBMqBw5+obzvKVPACgkRJS
jEbvyhlw3wF5vu3UinSyDIk=
=CVPy
-----END PGP SIGNATURE-----

    

- 漏洞信息

Mantis Multiple Remote Vulnerabilities
Unknown 15227
Yes No
2005-10-28 12:00:00 2006-04-03 07:33:00
The researchers responsible for discovering these issues are currently unknown.

- 受影响的程序版本

Mantis Mantis 0.19.2
Mantis Mantis 0.19.1
Mantis Mantis 0.19 .0RC1
Mantis Mantis 0.19 .0a2
Mantis Mantis 0.19 .0a1
Mantis Mantis 0.19 .0a
Mantis Mantis 0.19 .0
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Mantis Mantis 0.19.3

- 不受影响的程序版本

Mantis Mantis 0.19.3

- 漏洞讨论

Mantis is prone to multiple remote vulnerabilities. These issues can allow attackers to access sensitive information, execute arbitrary PHP scripts, and carry out cross-site scripting and SQL-injection attacks.

These issues occur in Mantis versions prior to 0.19.3.

- 漏洞利用

Exploit code is not required.

- 解决方案

Please see the referenced advisories for more information.

The vendor has released Mantis 0.19.3 to address these issues.


Mantis Mantis 0.19 .0a

Mantis Mantis 0.19 .0a1

Mantis Mantis 0.19 .0a2

Mantis Mantis 0.19 .0

Mantis Mantis 0.19 .0RC1

Mantis Mantis 0.19.1

Mantis Mantis 0.19.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站