CVE-2005-3080
CVSS5.0
发布时间 :2005-09-27 16:03:00
修订时间 :2008-09-05 16:53:24
NMCO    

[原文]contrib/example.php in GeSHi before 1.0.7.3 allows remote attackers to read arbitrary files via the language field without a source field set.


[CNNVD]GeSHI Example.PHP读取任意文件漏洞(CNNVD-200509-271)

        GeSHi(Generic Syntax Highlighter)用于在页面中高亮显示各种源代码。
        GeSHi 1.0.7.3之前版本中的contrib/example.php脚本存在安全漏洞,远程攻击者可通过没有源字段集的language字段读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:geshi:geshi:1.0.0
cpe:/a:geshi:geshi:1.0.7.1
cpe:/a:geshi:geshi:1.0.6
cpe:/a:geshi:geshi:1.0.4
cpe:/a:geshi:geshi:1.0.1
cpe:/a:geshi:geshi:1.0.7
cpe:/a:geshi:geshi:1.0.5
cpe:/a:geshi:geshi:1.0.7.2
cpe:/a:geshi:geshi:1.0.3
cpe:/a:geshi:geshi:1.0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3080
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3080
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-271
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14903
(PATCH)  BID  14903
http://sourceforge.net/project/shownotes.php?release_id=358285
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=358285

- 漏洞信息

GeSHI Example.PHP读取任意文件漏洞
中危 输入验证
2005-09-27 00:00:00 2005-10-20 00:00:00
远程  
        GeSHi(Generic Syntax Highlighter)用于在页面中高亮显示各种源代码。
        GeSHi 1.0.7.3之前版本中的contrib/example.php脚本存在安全漏洞,远程攻击者可通过没有源字段集的language字段读取任意文件。

- 公告与补丁

        暂无数据

- 漏洞信息

19599
GeSHi contrib/example.php Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Unknown Vendor Verified

- 漏洞描述

GeSHi contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when an input validation error in contrib/example.php occurs, which will disclose contents of arbitrary files resulting in a loss of confidentiality.

- 时间线

2005-09-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.7.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站