CVE-2005-3076
CVSS7.5
发布时间 :2005-09-27 15:03:00
修订时间 :2008-09-05 16:53:24
NMCO    

[原文]Simplog 0.9.1 might allow remote attackers to execute arbitrary SQL commands or trigger SQL error messages via invalid (1) pid, (2) blogid, (3) cid, or (4) m parameters to archive.php, or the (5) blogid parameter to blogadmin.php.


[CNNVD]Simplog中多个SQL注入漏洞(CNNVD-200509-275)

        Simplog ,能使你很容易地为现有的站点添加blog功能,它由php写成,兼容多数数据库,它的特点是强大并且简单.
        Simplog 0.9.1可能存在安全漏洞,远程攻击者通过无效的(1) 注入archive.php脚本的pid参数, (2) blogid参数, (3) cid参数, 或(4) archive.php脚本的m参数或(5) blogid参数可能执行任意SQL指令,或引起SQL出错信息。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3076
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3076
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-275
(官方数据源) CNNVD

- 其它链接及资源

http://www.simplog.org/bugs/bug.php?op=show&bugid=55
(UNKNOWN)  CONFIRM  http://www.simplog.org/bugs/bug.php?op=show&bugid=55
http://www.securityfocus.com/bid/14897
(UNKNOWN)  BID  14897
http://secunia.com/advisories/16881
(UNKNOWN)  SECUNIA  16881
http://securityreason.com/securityalert/755
(UNKNOWN)  SREASON  755

- 漏洞信息

Simplog中多个SQL注入漏洞
高危 输入验证
2005-09-27 00:00:00 2006-08-11 00:00:00
远程  
        Simplog ,能使你很容易地为现有的站点添加blog功能,它由php写成,兼容多数数据库,它的特点是强大并且简单.
        Simplog 0.9.1可能存在安全漏洞,远程攻击者通过无效的(1) 注入archive.php脚本的pid参数, (2) blogid参数, (3) cid参数, 或(4) archive.php脚本的m参数或(5) blogid参数可能执行任意SQL指令,或引起SQL出错信息。

- 公告与补丁

        暂无数据

- 漏洞信息

19581
Simplog archive.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Simplog contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the archive.php script not properly sanitizing user-supplied input to the 'pid' and 'cid' variables. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-09-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站