发布时间 :2005-09-27 15:03:00
修订时间 :2008-09-05 16:53:22

[原文]Unspecified vulnerability in Eric Integrated Development Environment (eric3) before 3.7.2 has unknown impact and attack vectors related to a "potential security exploit."


        Eric 是一个使用 Python 写成的功能完备的 Python IDE(集成开发环境)。它不仅可以作为开发 Python 程序的编辑器和 IDE,而且也支持 Ruby 语言。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  SECTRACK  1014947
(UNKNOWN)  BID  14905

- 漏洞信息

危急 输入验证
2005-09-27 00:00:00 2005-10-20 00:00:00
        Eric 是一个使用 Python 写成的功能完备的 Python IDE(集成开发环境)。它不仅可以作为开发 Python 程序的编辑器和 IDE,而且也支持 Ruby 语言。

- 公告与补丁

        eric3 eric3 3.4.2
        eric3 eric-3.7.2.tar.gz
        eric3 eric3 3.5
        eric3 eric-3.7.2.tar.gz
        eric3 eric3 3.5.1
        eric3 eric-3.7.2.tar.gz
        eric3 eric3 3.6
        eric3 eric-3.7.2.tar.gz
        eric3 eric3 3.6.1
        eric3 eric-3.7.2.tar.gz
        eric3 eric3 3.6.2
        Debian eric_3.6.2-2_all.deb
        Debian GNU/Linux 3.1 alias sarge
        eric3 eric-3.7.2.tar.gz
        eric3 eric3 3.7
        eric3 eric-3.7.2.tar.gz
        eric3 eric3 3.7.1
        eric3 eric-3.7.2.tar.gz

- 漏洞信息

Eric3 Project File Processing Arbitrary Code Execution
Location Unknown Attack Type Unknown
Loss of Integrity, Impact Unknown
Exploit Unknown Vendor Verified

- 漏洞描述

Eric Integrated Development Environment(Eric3) contains a flaw that may allow arbitrary code execution. The issue occurs when processing project files. No further details have been provided.

- 时间线

2005-09-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.7.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Eric3 Unspecified Arbitrary Code Execution Vulnerability
Input Validation Error 14905
No Yes
2005-09-22 12:00:00 2009-07-12 05:06:00
This vulnerability was announced by the vendor.

- 受影响的程序版本

SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
eric3 eric3 3.7.1
eric3 eric3 3.7
eric3 eric3 3.6.2
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
eric3 eric3 3.6.1
eric3 eric3 3.6
eric3 eric3 3.5.1
eric3 eric3 3.5
eric3 eric3 3.4.2
eric3 eric3 3.7.2

- 不受影响的程序版本

eric3 eric3 3.7.2

- 漏洞讨论

eric3 is affected by an arbitrary code execution vulnerability.

This issue is related to the processing of project files and may result in the execution of arbitrary python code.

Very little information is available on this issue. This BID will be updated as further information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

The vendor has addressed this issue in eric3 version 3.7.2.

Debian has released advisory DSA 869-1 to address this issue. Please see the referenced advisory for more information about obtaining and applying fixes.

SUSE has released advisory SUSE-SR:2005:025 to address this, and other issues in various packages, in various SUSE products. The advisory states that SUSE does not believe that this is a vulnerability, and will therefore not be releasing a fix. Please see the referenced advisory for further information.

eric3 eric3 3.4.2

eric3 eric3 3.5

eric3 eric3 3.5.1

eric3 eric3 3.6

eric3 eric3 3.6.1

eric3 eric3 3.6.2

eric3 eric3 3.7

eric3 eric3 3.7.1

- 相关参考